Package Details: libfm-qt6-git 1.3.0.8.gda59254-1

Git Clone URL: https://aur.archlinux.org/libfm-qt6-git.git (read-only, click to copy)
Package Base: libfm-qt6-git
Description: Qt port of libfm, a library providing components to build desktop file managers
Upstream URL: https://github.com/lxqt/libfm-qt
Licenses: LGPL
Conflicts: libfm-qt6
Provides: libfm-qt6
Submitter: yan12125
Maintainer: yan12125
Last Packager: yan12125
Votes: 2
Popularity: 0.55
First Submitted: 2023-01-24 07:26 (UTC)
Last Updated: 2023-10-10 09:46 (UTC)

Dependencies (9)

Sources (1)

Latest Comments

txtsd commented on 2024-03-13 06:11 (UTC)

The wip_qt6 branch has been merged into master. I think this package can be safely merged into libfm-qt-git once its deps are updated.

txtsd commented on 2023-11-10 11:56 (UTC)

I was actually wrong about this one. You're right.

I had to remove libfm-qt because it was pulling a dependency which created a conflict, IIRC, and made an incorrect assumption.

flexid2000 commented on 2023-11-08 23:19 (UTC)

I can confirm that all the packages are building now. I choose the following order, which is important: 1. lxqt-menu-data-git 2. lxqt-build-tools-qt6-git 3. libfm-qt6-git 4. pcmanfm-qt6-git 5. libdbusmenu-qt6 6. libqt6xdg-git 7. lxqt-qt6plugin-git

yan12125 commented on 2023-11-08 15:29 (UTC)

This should provide and conflict with libfm-qt, not with itself. That will take care of the dependency conflicts.

Could you describe more about dependency conflicts? This package is for Qt 6 and libfm-qt is for Qt 5, so one should not provide or conflict with another. On the other hand, this package provides/conflicts with the non-VCS package, not itself.

txtsd commented on 2023-11-08 12:31 (UTC)

This should provide and conflict with libfm-qt, not with itself. That will take care of the dependency conflicts.

yan12125 commented on 2023-06-12 16:03 (UTC)

@flexid2000: By "remove the lxqt group completely", do you mean removing official LXQt packages in Arch (lxqt-config, lxqt-panel, ...)? If so, unfortunately the answer is you'll need to do that - official LXQt packages use the stable version, which is not always compatible with -git version.

If you're using lxqt-panel-git or lxqt-config-git, discussions starting from https://github.com/lxqt/lxqt/pull/2423#issuecomment-1543884964 may help.

flexid2000 commented on 2023-06-12 14:45 (UTC)

Installing libfm-qt6-qt I run into a dependency hell. The attempt to install its dependency lxqt-menu-data-git gives me the error messages that certain files do already exist in the file system—and cannot be overwritten. Is there another way to install the qt6 packages without having to remove the lxqt group completely and installing it from git?

yan12125 commented on 2023-06-05 17:35 (UTC)

Thanks for the reminder. Both this and pcmanfm-qt6-git are updated.

mitch_mg2 commented on 2023-06-05 15:20 (UTC)

Please add the dependency of lxqt-menu-data for compilation, per upstream bug.

https://github.com/lxqt/libfm-qt/pull/905