Package Details: libfprint-1 1.0-1

Git Clone URL: https://aur.archlinux.org/libfprint-1.git (read-only, click to copy)
Package Base: libfprint-1
Description: Library for fingerprint readers - old stable version
Upstream URL: https://fprint.freedesktop.org/
Licenses: LGPL
Groups: fprint
Provides: libfprint
Submitter: gborzi
Maintainer: gborzi
Last Packager: gborzi
Votes: 11
Popularity: 0.007878
First Submitted: 2020-08-27 12:59 (UTC)
Last Updated: 2020-08-27 12:59 (UTC)

Latest Comments

muflone commented on 2024-04-07 21:03 (UTC) (edited on 2024-04-07 21:11 (UTC) by muflone)

@gborzi

As pointed from the Arch package guidelines page all the direct dependencies must be declared.

Only base-devel is assumed to be installed for AUR packages

So please add udev if it's required from the package. pacman -Qi udev to see how many other packages declare udev dependency

(there's a pending orphan request, not yet canceled)

mbromilow commented on 2024-02-04 15:16 (UTC)

Hi, please add udev (supplied by systemd) as it is still a missing (required) dependency. You can verify this since the package will not build in a clean chroot without it (e.g. by using extra-x86_64-build).

@hasmar04 -- pkgconf is not a missing dependency because using the AUR requires base-devel, which the pkgconf is a part of.

hasmar04 commented on 2024-01-14 08:09 (UTC)

pkgconf should be added to the required dependencies. Failed to install on Manjaro 23.1.3 without it.

yochananmarqos commented on 2022-04-23 20:32 (UTC)

@gborzi: If that's the case, then why do 318 packages require systemd? The current libfprint depends on systemd. Maybe you're thinking of the base-devel group?

gborzi commented on 2022-04-23 20:30 (UTC)

systemd belongs to base, it should not appear in depends/makedepends.

yochananmarqos commented on 2022-04-23 16:15 (UTC)

systemd is missing from makedepends():

Run-time dependency udev found: NO (tried pkgconfig)

libfprint/meson.build:103:8: ERROR: Dependency "udev" not found, tried pkgconfig

Josh68 commented on 2021-10-13 15:31 (UTC)

Hello. Any thoughts on this error trying to build (for libfingerprint-gui)? Thanks

Run-time dependency glib-2.0 found: NO (tried pkgconfig and cmake)

libfprint/meson.build:44:0: ERROR: Dependency "glib-2.0" not found, tried pkgconfig and cmake