Package Details: libftd2xx 1.3.6-1

Git Clone URL: https://aur.archlinux.org/libftd2xx.git (read-only)
Package Base: libftd2xx
Description: Library that allows a direct access to a USB FTDI2XX chip based device
Upstream URL: http://www.ftdichip.com/
Licenses: GPL
Submitter: None
Maintainer: aLostEngineer
Last Packager: aLostEngineer
Votes: 40
Popularity: 0.306838
First Submitted: 2009-01-16 02:21
Last Updated: 2015-10-30 14:34

Dependencies (2)

Sources (2)

Latest Comments

aLostEngineer commented on 2015-10-30 14:36

I've taken ownership and updated to the latest version. I've also decided to install and keep the static library file (libftd2xx.a) in case it's used in some cases.

Let me know if there are any issues!

kyak commented on 2015-10-23 15:40

I'm not using this package any more. Feel free to adopt.

goodmen commented on 2015-03-23 08:21

arch=('i686' 'x86_64')
there should be no comma between 'i686' and 'x86_64'

kyak commented on 2013-04-06 15:32

Changed libusb->libusbx in depends

hatred commented on 2012-12-11 00:26

@kyak, no problems, you are welcome :-)

kyak commented on 2012-12-10 15:39

Nice catch, guys!
@hatred, i just adopted your changes. I hope i did it right, since i'm on x86_64 and can't test. Thanks for the hint.

hatred commented on 2012-12-10 00:58

@gm99

Heh, libftd compile only for i386. You can modify PKGBUILD like:
1. before 'package()' add next two line:
_CARCH=${CARCH}
[ "${CARCH}" == "i686" ] && _CARCH=i386

2. replace all entries of '${CARCH}' inside 'package()' to '${_CARCH}'

3. save and call 'makepkg'

Anonymous comment on 2012-12-09 18:26

Hi kyak,
version 1,1.12-0 doen't compile.
Here is my log:
==> Making package: libftd2xx 1.1.12-0 (Sun Dec 9 15:46:04 CET 2012)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
-> Downloading libftd2xx1.1.12.tar.gz...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 928k 100 928k 0 0 284k 0 0:00:03 0:00:03 --:--:-- 288k
-> Found 55-ft2232.rules
==> Validating source files with md5sums...
libftd2xx1.1.12.tar.gz ... Passed
55-ft2232.rules ... Passed
==> Extracting Sources...
-> Extracting libftd2xx1.1.12.tar.gz with bsdtar
==> Starting package()...
install: cannot stat '/root/AUR/libftd2xx/src/release/build/i686/libftd2xx.so.1.1.12': No such file or directory
==> ERROR: A failure occurred in package().
Aborting...

Any hints are welcome.
Thank you for your help.

lxuyrbwy commented on 2012-09-18 14:01

Oh, and maybe remove the post-install/upgrade message about usbfs. You don't need to mount it anymore and it exists in /dev/bus/usb instead of /proc/usb.

lxuyrbwy commented on 2012-09-18 13:53

Version 1.1.12 is out.
PKGBUILD needs to be adapted.
Library files are now in release/$CARCH/build

My PKGBUILD:
http://pastebin.com/wbTdRpjv

hatred commented on 2011-01-07 15:33

1.0.0 version is avail