Package Details: libgcj17-bin 1:6.3.0_18+deb9u1-1

Git Clone URL: https://aur.archlinux.org/libgcj17-bin.git (read-only)
Package Base: libgcj17-bin
Description: Dynamically load and interpret java class files. Built from binary executables available in Debian repositories.
Upstream URL: http://gcc.gnu.org/java/
Licenses: GPL
Conflicts: gcc-gcj
Submitter: The-Compiler
Maintainer: The-Compiler
Last Packager: The-Compiler
Votes: 93
Popularity: 2.936704
First Submitted: 2016-08-09 07:31
Last Updated: 2018-06-25 10:12

Latest Comments

1 2 Next › Last »

totsilence commented on 2018-06-25 10:04

Hi, the PKGBUILD has +x permissions (755). I believe it should be changed to to 644.

The-Compiler commented on 2018-06-25 07:32

No clue why newer versions were dropped by debian, but I just pushed the downgraded version (with the horrible version number 1:6.3.0_18+deb9u1-1).

samk commented on 2018-06-25 07:21

Thanks. But could that not be changed also in the original PKGBUILD? After installing with the modified PKGBUILD, how can I disable the notification to update? (Now, I need to unselect, everytime I update). Best regards

cmsigler commented on 2018-06-22 18:32

Bad form and all to post a diff patch, but here it is for your ease of use:

======== CUT HERE ========

--- PKGBUILD.orig 2018-06-22 14:09:27.000000000 -0400

+++ PKGBUILD 2018-06-22 14:18:40.123851361 -0400

@@ -4,20 +4,22 @@

# Contributor: Roberto Calabrese <robertocalabrese75 [at]="" gmail.com=""></robertocalabrese75>

pkgname=libgcj17-bin

-pkgver=6.4.0_13

+pkgver=6.3.0_18+deb9u1

pkgrel=1

pkgdesc="Dynamically load and interpret java class files. Built from binary \

executables available in Debian repositories."

url=http://gcc.gnu.org/java/

-arch=(i686 x86_64)

+arch=('i686' 'x86_64')

license=(GPL)

conflicts=(gcc-gcj)

depends=(zlib)

source_i686=(http://ftp.debian.org/debian/pool/main/g/gcc-6/${pkgname%-}${pkgver%}-${pkgver##*_}_i386.deb)

source_x86_64=(http://ftp.debian.org/debian/pool/main/g/gcc-6/${pkgname%-}${pkgver%}-${pkgver##*_}_amd64.deb)

-sha1sums_i686=('949796af87b86f808b20818fde45b8a735fcad5a')

-sha1sums_x86_64=('2841f49b2f785d38367973b71ccd1907e1dc6c88')

+#sha1sums_i686=('949796af87b86f808b20818fde45b8a735fcad5a')

+#sha1sums_x86_64=('2841f49b2f785d38367973b71ccd1907e1dc6c88')

+md5sums_i686=('c187b42c6feb1c81c37e91f2d25bd4f0')

+md5sums_x86_64=('fdd9f60d3e862db995b8dfdd3fde14d4')

prepare() {

tar xf data.tar.*

======== CUT HERE ========

As always, HTH.

Clemmitt Sigler

samk commented on 2018-06-19 06:46

I had to apply the same solution as to7m. And it worked. Searched the debian ftp, and there is no newer version available. Probably, the libgcj17-dev_6.4.0-7_kfreebsd-amd64.deb could do. Not sure, if kfreebsd would work...

to7m commented on 2018-06-07 13:05

I got the libgcj17-bin PKGBUILD to work by changing pkgver=6.4.0_13 to pkgver=6.3.0_18

and _amd64.deb) to +deb9u1_amd64.deb)

and putting the correct sha1sum in.

That might be a bad way to do it, I have no idea :')

Edit: I'm thinking this means the PKGBUILD is out-of-date and will flag it as such.

kaploceh commented on 2018-06-06 19:44

I can confirm GermainZ's comment.. pdftk-bin only works with 12.

When updating to 13

 curl: (22) The requested URL returned error: 404 Not Found
 ==> ERROR: Failure while downloading 
 <http://ftp.debian.org/debian/pool/main/g/gcc-6/libgcj17_6.4.0-13_amd64.deb>
Aborting...

GermainZ commented on 2018-05-31 10:35

http://ftp.debian.org/debian/pool/main/g/gcc-6/libgcj17_6.4.0-13_amd64.deb seems to return a 404 as well now. Going back to -12 instead of -13 works.

The-Compiler commented on 2018-03-22 07:34

@FrederickZh whoops, not sure how that happened - indeed, some packages there are at -15 but libgcj isn't yet. Back on -13 it is for now. Sorry!

FrederickZh commented on 2018-03-22 06:57

Got http 404 for http://ftp.debian.org/debian/pool/main/g/gcc-6/libgcj17_6.4.0-15_amd64.deb?