Package Details: libgnome 2.32.1-8

Git Clone URL: https://aur.archlinux.org/libgnome.git (read-only, click to copy)
Package Base: libgnome
Description: Common libraries for GNOME
Upstream URL: http://www.gnome.org
Licenses: LGPL
Submitter: PhotonX
Maintainer: PhotonX (kevr)
Last Packager: PhotonX
Votes: 60
Popularity: 0.023551
First Submitted: 2017-01-26 07:39 (UTC)
Last Updated: 2021-03-28 18:12 (UTC)

Latest Comments

PhotonX commented on 2021-06-23 16:15 (UTC) (edited on 2021-06-23 16:18 (UTC) by PhotonX)

@JohnRobson: I absolutely don't understand how this can happen. I downloaded the source file from https://download.gnome.org/sources/libgnome/2.32/libgnome-2.32.1.tar.bz2 and get

$ sha256sum libgnome-2.32.1.tar.bz2

b2c63916866485793b87398266dd7778548c1734923c272a94d84ee011b6f7a4 libgnome-2.32.1.tar.bz2

JohnRobson commented on 2021-06-22 20:38 (UTC)

@PhotonX

$ sha256sum *
c2521ed5985159b33a0a5bf53b89012abd9521391fc8ce4c9c73289ca18eb147  0001-Don-t-use-G_DISABLE_DEPRECATED.patch
b86a3a1ef9df2314029a418ea26cadeadb1cf2da30536b850f7c98a6d8ce2220  05_glib-2.54-ftbfs.patch
2de9ee8b5562a3884d582c7e646a0705a9f813a2889264164609d351cdcc4998  libgnome-2.32.1.tar.bz2
9b3e2b7583f52689e82b86a0fa0d7370fcec4a3515fe1863a9cce906910788ae  PKGBUILD

0 drwxr-xr-x 20   440 2021-06-22 16:32:27.629386403 -0400 ../
4 -rw-r--r--  1  1004 2021-06-22 16:32:28.432719717 -0400 .SRCINFO
4 -rw-r--r--  1  1911 2021-06-22 16:32:28.432719717 -0400 PKGBUILD
4 -rw-r--r--  1   674 2021-06-22 16:32:28.432719717 -0400 05_glib-2.54-ftbfs.patch
4 -rw-r--r--  1   788 2021-06-22 16:32:28.432719717 -0400 0001-Don-t-use-G_DISABLE_DEPRECATED.patch
0 drwxr-xr-x  8   280 2021-06-22 16:32:28.452719717 -0400 .git/
0 drwxr-xr-x  2    40 2021-06-22 16:32:35.446052883 -0400 src/
8 -rw-r--r--  1  7836 2021-06-22 16:32:35.786052875 -0400 libgnome-2.32.1.tar.bz2
0 drwxr-xr-x  4   180 2021-06-22 16:32:35.799386209 -0400 ./

PhotonX commented on 2021-03-30 19:29 (UTC)

@JohnRobson, I just checked and the sha256sum is still correct. I don't understand why it fails for you. Could you please post the sha256sum of your libgnome-2.32.1.tar.bz2 file?

PhotonX commented on 2021-03-30 15:23 (UTC)

That's weird, I didn't change the source file's sha256sum, so it seems that the file has been modified upstream... I will have a look into it.

JohnRobson commented on 2021-03-30 14:58 (UTC)

==> Validating source files with sha256sums...
libgnome-2.32.1.tar.bz2 ... FAILED
0001-Don-t-use-G_DISABLE_DEPRECATED.patch ... Passed
05_glib-2.54-ftbfs.patch ... Passed
==> ERROR: One or more files did not pass the validity check!
error downloading sources: libgnome (libgnome-data libgnome)

PhotonX commented on 2021-03-28 18:12 (UTC)

Thanks, done!

rafaelff commented on 2021-03-28 14:22 (UTC)

Please add gtk-doc to makedepends in order to solve this:

Can't exec "gtkdocize": No such file or directory at /usr/share/autoconf/Autom4te/FileUtils.pm line 293.
autoreconf: error: gtkdocize failed with exit status: 2

PhotonX commented on 2017-11-04 12:38 (UTC)

@Akidso: Could you please post the complete error output you are getting? The two outputs you posted are completely different. :)

Adikso commented on 2017-11-04 12:33 (UTC) (edited on 2017-11-04 12:33 (UTC) by Adikso)

@PhotonX It happens during build of libgnome: Traceback (most recent call last): [...] UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 2123: ordinal not in range(128) make[2]: *** [Makefile:691: install-data-local] Error 1 make[2]: Leaving directory '/tmp/yaourt-tmp-adikso/aur-libgnome/src/libgnome-2.32.1/doc/reference' make[1]: *** [Makefile:469: install-am] Error 2 make[1]: Leaving directory '/tmp/yaourt-tmp-adikso/aur-libgnome/src/libgnome-2.32.1/doc/reference' make: *** [Makefile:399: install-recursive] Error 1 make: Leaving directory '/tmp/yaourt-tmp-adikso/aur-libgnome/src/libgnome-2.32.1/doc'

PhotonX commented on 2017-11-02 20:34 (UTC)

@Adikso: Unfortunately, I'm not able to reproduce this. Are you sure that this output comes when building libgnome and not some of its dependencies?

Adikso commented on 2017-11-02 14:26 (UTC)

I am getting this error during building: Traceback (most recent call last): File "/usr/bin/gtkdoc-rebase", line 56, in <module> sys.exit(rebase.run(options)) File "/usr/share/gtk-doc/python/gtkdoc/rebase.py", line 73, in run ScanDirectory(dir, options) File "/usr/share/gtk-doc/python/gtkdoc/rebase.py", line 131, in ScanDirectory ScanDirectory(subdir, options) File "/usr/share/gtk-doc/python/gtkdoc/rebase.py", line 104, in ScanDirectory o = ReadDevhelp(scan_dir, entry) File "/usr/share/gtk-doc/python/gtkdoc/rebase.py", line 137, in ReadDevhelp for line in open(os.path.join(dir, file)): File "/usr/lib/python3.6/encodings/ascii.py", line 26, in decode return codecs.ascii_decode(input, self.errors)[0] UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 2123: ordinal not in range(128)

PhotonX commented on 2017-10-11 12:51 (UTC)

Finally had the time to look into it, the bug is fixed using the patch from https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=870742

PhotonX commented on 2017-10-07 20:43 (UTC)

Thanks for the report, I can reproduce it and will have a look asap!

h313 commented on 2017-10-07 20:00 (UTC)

I'm getting this error when building with makepkg -si: Traceback (most recent call last): File "/usr/bin/glib-mkenums", line 688, in <module> File "/usr/bin/glib-mkenums", line 688, in <module> process_file(fname) File "/usr/bin/glib-mkenums", line 420, in process_file process_file(fname) File "/usr/bin/glib-mkenums", line 420, in process_file line = curfile.readline() File "/usr/lib/python3.6/codecs.py", line 321, in decode line = curfile.readline() File "/usr/lib/python3.6/codecs.py", line 321, in decode (result, consumed) = self._buffer_decode(data, self.errors, final) UnicodeDecodeError: 'utf-8' codec can't decode byte 0xa0 in position 3214: invalid start byte (result, consumed) = self._buffer_decode(data, self.errors, final) UnicodeDecodeError: 'utf-8' codec can't decode byte 0xa0 in position 3214: invalid start byte

PhotonX commented on 2017-02-14 15:51 (UTC)

libgnome-data is created when you build libgnome (libgnome is a split package). It works for me with yaourt, please ask the developer of aura for support.

nurfz commented on 2017-02-14 15:16 (UTC)

$ sudo aura -A libgnome-data aura >>= The following are not AUR packages: libgnome-data Why is this package not found?