Package Details: libgpiod-git r983.03a6c2f-1

Git Clone URL: https://aur.archlinux.org/libgpiod-git.git (read-only, click to copy)
Package Base: libgpiod-git
Description: C library and tools for interacting with the linux GPIO character device
Upstream URL: https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git
Licenses: LGPL2.1
Conflicts: libgpiod
Provides: libgpiod
Submitter: OdysseusGE
Maintainer: OdysseusGE
Last Packager: OdysseusGE
Votes: 4
Popularity: 0.000000
First Submitted: 2017-08-26 21:10 (UTC)
Last Updated: 2022-11-26 10:24 (UTC)

Latest Comments

1 2 Next › Last »

OdysseusGE commented on 2022-11-26 10:27 (UTC)

@tmonjalo,

Thanks for the report and workaround. I've updated the PKGBUILD.

tmonjalo commented on 2022-11-25 13:57 (UTC) (edited on 2022-11-25 13:59 (UTC) by tmonjalo)

As a workaround for the Python bindings packaging:

sed -i 's,--prefix=$(prefix),--root=$(top_builddir)/../../pkg/libgpiod-git/,' src/libgpiod/bindings/python/Makefile.am

tmonjalo commented on 2022-11-24 22:11 (UTC)

Error:

GPIOD_WITH_TESTS= \ /usr/bin/python setup.py install --prefix=/usr running install /usr/lib/python3.10/site-packages/setuptools/command/install.py:34: SetuptoolsDeprecationWarning: setup.py install is deprecated. Use build and pip and other standards-based tools. warnings.warn( /usr/lib/python3.10/site-packages/setuptools/command/easy_install.py:144: EasyInstallDeprecationWarning: easy_install command is deprecated. Use build and pip and other standards-based tools. warnings.warn( error: can't create or remove files in install directory

The following error occurred while trying to add or remove files in the installation directory:

[Errno 13] Permission denied: '/usr/lib/python3.10/site-packages/test-easy-install-15659.write-test'

The installation directory you specified (via --install-dir, --prefix, or the distutils default setting) was:

/usr/lib/python3.10/site-packages/

AlexanderStein commented on 2020-11-19 09:39 (UTC)

Starting from commit v1.6-18-g21f7744 (git describe) linux-api-headers>=5.10 is required

OdysseusGE commented on 2018-05-04 06:46 (UTC)

@shenghaoyang,

Thanks, fixed.

shenghaoyang commented on 2018-05-04 04:17 (UTC)

@OdysseusGE, Thanks for enabling them, but I think you left out "-python" in the last "enable-bindings" line in the PKGBUILD.

OdysseusGE commented on 2018-04-29 20:11 (UTC)

@shenghaoyang,

I've enabled the bindings support and included python as a dependency.

shenghaoyang commented on 2018-04-29 13:24 (UTC)

Hello @OdysseusGE, could you add in the options to enable the bindings?

They are --enable-bindings-cxx and --enable-bindings-python respectively.