Package Details: libgtkhtml 2.11.1-6

Git Clone URL: https://aur.archlinux.org/libgtkhtml.git (read-only)
Package Base: libgtkhtml
Description: An HTML library for GTK
Upstream URL: http://www.gnome.org
Licenses: GPL
Submitter: jose1711
Maintainer: jose1711
Last Packager: jose1711
Votes: 4
Popularity: 0.000400
First Submitted: 2015-12-11 13:29
Last Updated: 2017-09-21 13:34

Latest Comments

Harey commented on 2017-09-26 07:49

pacman -Ss gnome-vfs doesn't find any packages... Did you mean 'gvfs'? In the official repos this seems to be splitted in various packages by now, one of them beeing gvfs-smb. And yes, optdepend if it builds without.

jose1711 commented on 2017-09-25 18:17

i guess something was broken on your system that day. thinking about moving gnome-vfs to optdepends. comments?

Harey commented on 2017-09-25 09:30

I already removed everything installed in the first attempt. Today a makepkg -cfsi resulted in a proper build process. Don't ask me why I did not succeed in the first try. I am happy that I copied the error here so you don't think I am fooling you ;)

BTW, the cubesql admin app for which I needed the lib now simply dies when accessing its news panel instead of telling me it needs libgtkhtml - I think because it needs a 32bit variant...

jose1711 commented on 2017-09-25 09:04

i confirm, after removing gnome-vfs-nosmb it still builds on my box. harey: can you remove gnome-vfs-nosmb (+ dependencies), do makepkg and provide output of config.log?

Snark1994 commented on 2017-09-24 15:56

(The relevant bit from the configure log is:

checking for GNOME_VFS... no
configure: WARNING: *** test apps will be built without GNOME VFS support.
configure: creating ./config.status
config.status: creating Makefile

)

Snark1994 commented on 2017-09-24 15:54

I do not have it installed.

jose1711 commented on 2017-09-23 23:51

@Snark1994

please can you tell if you have gnome-vfs installed?

check out libgtkhtml configure script:
echo $ECHO_N "checking for GNOME_VFS... $ECHO_C" >&6; }

Snark1994 commented on 2017-09-23 19:32

I don't think gnome-vfs-nosmb is the correct dependency; I could build this package beforehand without it, and if you check the package with namcap then it is flagged as unneeded. Perhaps the easiest thing to do is to remove the dependency, and then use namcap to check the package - it should flag up any dependencies that are needed but not listed and will hopefully find the culprit. (It also has some other warnings/comments about the pkgbuild.)

jose1711 commented on 2017-09-21 14:09

thank you, should be fixed now

Harey commented on 2017-09-21 13:13

No, I haven't, as it is not listed as a dependency. After building and installing gnome-vfs-nosmb (which by the way pulled in another bunch of dependencies) the build process is working.

All comments