Package Details: libicu53 53.2-2

Git Clone URL: https://aur.archlinux.org/libicu53.git (read-only, click to copy)
Package Base: libicu53
Description: International Components for Unicode library (version 53)
Upstream URL: https://icu.unicode.org
Keywords: icu
Licenses: custom:icu
Provides: libicudata.so.53, libicui18n.so.53, libicuio.so.53, libicutest.so.53, libicutu.so.53, libicuuc.so.53
Submitter: ttc0419
Maintainer: ttc0419
Last Packager: ttc0419
Votes: 2
Popularity: 0.037964
First Submitted: 2022-07-23 08:12 (UTC)
Last Updated: 2022-07-23 12:43 (UTC)

Latest Comments

ttc0419 commented on 2022-07-23 12:26 (UTC) (edited on 2022-07-23 12:30 (UTC) by ttc0419)

@FabioLolix Thanks for the code review,

  • This package only provide shared libraries, it is possible to provide a full installation of the program with the latest version side by side. So, I'm leaving the icu53 name for anyone want to do that.
  • Removed
  • I was thinking about providing libicu*.so=53, the AUR page seems not be able to reflect what I meant. After a second thought, libicu*.so.53 should be the correct answer.

FabioLolix commented on 2022-07-23 08:42 (UTC)

Hello,

  • this kind of pkgbuild are usually called icu, like icu53 https://aur.archlinux.org/packages?O=0&SeB=n&K=icu&outdated=&SB=p&SO=d&PP=50&submit=Go
  • -j 8, don't specify the number of makejobs, that up for user configurations
  • this can't provide "libicudata.so, libicui18n.so, libicuio.so, libicutest.so, libicutu.so, libicuuc.so" as it is not a replacement of icu from official repository, replacing icu with this package will result in a fail to start for every programs that need it