Package Details: libimobiledevice-git 1:1.2.0.r13.gdf1f5c4-2

Git Clone URL: https://aur.archlinux.org/libimobiledevice-git.git (read-only)
Package Base: libimobiledevice-git
Description: libimobiledevice is a software library that talks the protocols to support iPhone and iPod Touch devices on Linux
Upstream URL: http://www.libimobiledevice.org/
Licenses: GPL2, LGPL2.1
Conflicts: libimobiledevice, libiphone, libiphone-git
Provides: libimobiledevice, libiphone, libiphone-git
Submitter: None
Maintainer: None
Last Packager: intelfx
Votes: 46
Popularity: 0.210303
First Submitted: 2010-03-25 16:57
Last Updated: 2016-03-26 14:25

Required by (20)

Sources (1)

Latest Comments

intelfx commented on 2016-03-26 14:29

Oops. Build fixed.

Either way, I don't own any Apple mobile devices anymore, so I'm going to disown all libimobiledevice packages that I maintained until now.

mistrall commented on 2016-03-14 10:44

i've patched src like this and it worked

http://pastebin.com/VykuyXNK

Mangix commented on 2016-03-13 21:20

just tried building. errors with

|../src/.libs/libimobiledevice.so: undefined reference to `SSLv3_method'|

newmentos commented on 2016-03-11 13:37

CC idevice_id-idevice_id.o
CCLD idevice_id
../src/.libs/libimobiledevice.so: undefined reference to `SSLv3_method'
collect2: error: ld returned 1 exit status

intelfx commented on 2015-03-12 01:17

- sanitized deps
- updated pkgver() to cope with non-annotated tags
- updated pkgver() to place 'r' in front of revision #

ubuntuaddicted commented on 2014-12-12 14:43

i'm not sure why the libimobiledevice website says it's working with iphone 5S running up to firmware 8.1.1 because i can't get clementine to work with my 5S. It does not show up as a device in clementine.

intelfx commented on 2014-11-29 11:02

@karronoli:
Users of the AUR are expected to have package group 'base-devel' installed (which includes the 'libtool' package). AUR packages do not list dependencies on packages from this group.

Reference:
https://wiki.archlinux.org/index.php/AUR#Prerequisites
"Warning: Packages in the AUR assume the base-devel group is installed, and AUR packages will not list members of this group as dependencies even if the package cannot be built without them. Please ensure this group is installed before complaining about failed builds."

karronoli commented on 2014-11-29 10:13

libtool dependency is not enough on the PKGBUILD?
libtoolize was not executed. I could installed libimobiledevice-git-1:1.1.0.588.g53eb963-1

karronoli commented on 2014-11-29 10:10

libtool dependency is not enough on PKGBUILD?
I could not execute libtoolize. I installed libimobiledevice-git-1:1.1.0.588.g53eb963-1

intelfx commented on 2014-10-27 07:42

Adopted, fixed cyclic dep, removed swig makedep.

vmalloc commented on 2014-10-09 18:32

yes PKGBUILD is changed.

usbmuxd-git to libusbmuxd-git


anatolik commented on 2014-10-04 02:15

There is a cyclic dependency between libimobiledevice-git and usbmuxd-git

vmalloc commented on 2014-09-30 14:57

here the new package. This solves the problem.

http://archpkgs.cyborg-connect.de/

parkerlreed commented on 2014-04-16 15:44

libimobiledevice-git needs libusbmuxd-git. libusbmuxd-git can't install due to usbmuxd being on the system (and quite a few things depend on it). Edit the PKGBUILD to point to usbmuxd-git instead. usbmuxd-git depends on libimobiledevice-git. Okay... ;_;

alexbrinister commented on 2013-11-15 02:54

Yes, it is. I just fixed both this package and usbmuxd-git.

alexbrinister commented on 2013-11-15 02:32

migerh commented on 2013-11-14 17:24

@intelfx: I'm new to AUR and Arch packaging so I'm not sure but libusbmuxd is actually a dependency of libimobiledevice, too. At least upstream says so:

http://cgit.sukimashita.com/libimobiledevice.git/tree/configure.ac#n37

intelfx commented on 2013-11-14 16:20

Here we go again... (please take a look at usbmuxd-git comments if you didn't)

- PYTHON=python2 given instead of disabling cython (for minimal deviation from official package)
- libusbmuxd-git dependency moved to usbmuxd-git
- provides=(... "libimobiledevice=1.2") is wrong since the version (as in config.h) is 1.1.6

ftp://intelfx.dyndns.org/libimobiledevice-git-1:1.1.0.406.g3c3a791-2.src.tar.gz

intelfx commented on 2013-10-20 21:19

Could you please update the PKGBUILD? A better pkgver() can be used, libplist may be replaced with libplist-git and there is a couple of fixes to the build process...

You can find the updated package here:
ftp://intelfx.dyndns.org/libimobiledevice-git-1:1.1.0.353.gc7c49ae-1.src.tar.gz

nac2013 commented on 2013-10-06 06:14

which version is this ? the one in the git is 1.1.6
>>nathan:[~/libi/libimobiledevice]$ cat ./configure.ac
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.

AC_PREREQ(2.61)
AC_INIT(libimobiledevice, 1.1.6, nospam@nowhere.com)
---
and thogh i have python 3 installed it keeps giving me
configure: error: in `/home/nathan/libi/libimobiledevice':
configure: error:
This version of the AC_PYTHON_DEVEL macro
doesn't work properly with versions of Python before
2.1.0. You may need to re-run configure, setting the
variables PYTHON_CPPFLAGS, PYTHON_LDFLAGS, PYTHON_SITE_PKG,
PYTHON_EXTRA_LIBS and PYTHON_EXTRA_LDFLAGS by hand.
Moreover, to disable this check, set PYTHON_NOVERSIONCHECK
to something else than an empty string.

See `config.log' for more details
>>nathan:[~/libi/libimobiledevice]$ python
Python 3.3.2 (default, Sep 6 2013, 09:35:59)
[GCC 4.8.1 20130725 (prerelease)] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import sys, string;
>>> ver = string.split(sys.version)[0];
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
AttributeError: 'module' object has no attribute 'split'
>>>
found the split is causing the error for some reason , help ?

Anonymous comment on 2013-04-26 15:31

Still breaks upower - after i install libimobiledevice-git and restart, systemd stops because of upower problems.

alexbrinister commented on 2013-04-11 22:41

Fixed.

jft commented on 2013-04-11 20:59

Breaks upower and thus gnome3 currently. upower depends on /usr/lib/libimobiledevice.so.3 but but this package provides /usr/lib/libimobiledevice.so.4.

oriba commented on 2012-12-16 03:31

ah, the usbmuxd-git in the deen ds is nt necessary, because there already is usbmuxd available via pacman.
But as I now saw, libimobiledevice itself also is available via pacman.
Thats nice :-)
But it would be better if this would be mentioned on AUR, it took my a while until - by chance - found it out....

gpain commented on 2012-07-31 22:02

Thanks a lot mtwomey!
You were right, I needed to install libtool and everything went like a charm.

Anonymous comment on 2012-07-31 02:11

@gpain I had this exact same issue. Turns out I was missing libtool (this was noted near the beginning of the build process).

sebikul commented on 2012-07-19 00:08

@gpain: It builds just fine on a clean chroot. Could you be more specific please?

Anyway, I updated the PKGBUILD to remove some unused features.

gpain commented on 2012-07-18 22:46

Unable to install it (usbmuxd-git was ok) in x86_64

http://pastebin.com/suK8dPnW

gpain commented on 2012-07-18 22:40

Unable to install it (usbmuxd-git was ok) in x86_64

http://pastebin.com/suK8dPnW

gpain commented on 2012-07-18 21:54

Unable to install it (usbmuxd-git was ok) in x86_64

http://pastebin.com/suK8dPnW

gpain commented on 2012-07-18 21:45

Not able to install libimobiledevice-git (usbmuxd-git was ok)

Log. http://pastebin.com/suK8dPnW

sebikul commented on 2012-05-22 01:32

Glad to be able to help! Thanks for your help!

jgottula commented on 2012-05-22 01:21

I can also confirm that both packages build on x86_64, and everything is neater and tidier now too. Thanks!

graysky commented on 2012-05-22 01:14

Thanks sebikul - usbmuxd-git builds just fine and so does libmobiledevice-git.

You're the man!

sebikul commented on 2012-05-22 00:16

Okay, both libimobiledevice and usbmuxd where updated. They should build fine on a i686 system. Unfortunately, i can't test on a x64 system, can somebody confirm? I would like to than everybody who reported bugs and suggestions.

sebikul commented on 2012-05-22 00:00

I'm already working on a clean fix. It has more or less to do with what you just explained, but instead of moving files, it tells cmake to install them just where we need them to be. I'll keep you posted.

jgottula commented on 2012-05-21 23:24

The file /usr/lib/pkgconfig/libusbmuxd.pc needs to be present. A quick fix is to add these two lines to the end of the build() function in the PKGBUILD for usbmuxd-git:

mkdir -p $pkgdir/usr/lib/pkgconfig
cp $srcdir/$_gitname-build/libusbmuxd.pc $pkgdir/usr/lib/pkgconfig/

If you rebuild your usbmuxd-git package with that modification, then this build should work.

There's probably a more 'correct' way to make this happen, but I'm not familiar enough with CMake to know what that would be.

graysky commented on 2012-05-21 21:40

@seb - log for usbmuxd-git:

http://pastebin.com/gxdmn3Pm

sebikul commented on 2012-05-21 19:59

Could you also uplaod the .log files when building usbmuxd please?
My guess is that the hardcoded PKG_CONFIG_PATH needs a conditional depending on the client's architecture.

graysky commented on 2012-05-21 19:51

No problem - http://pastebin.com/eReuRpx4

sebikul commented on 2012-05-21 18:12

@graysky, i686, what's the output when compiling on a x86_64 chroot? Upload the *.log files to pastebin please.

graysky commented on 2012-05-21 07:55

Sebikul - x86_64 or i686? I can build it on i686 (chroot) but not on x86_64.

graysky commented on 2012-05-21 07:53

Is it just me? Can anyone else build this guy?

sebikul commented on 2012-05-21 05:06

I wasn't doing it initially, but I followed your suggestion and gave it a try. It built without problem in a clean chroot, and on my (dirty) system. I can't say exactly what is failing on your side. Sorry :S

graysky commented on 2012-05-21 04:42

@sebikul - have you run it in a clean chroot? For me, this fails just like when I run it outside of a clean chroot.


checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for libusbmuxd... no
configure: error: Package requirements (libusbmuxd >= 1.0.8) were not met:

No package 'libusbmuxd' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

See, https://wiki.archlinux.org/index.php/DeveloperWiki:Building_in_a_Clean_Chroot

sebikul commented on 2012-05-20 21:56

checking how to hardcode library paths into programs... immediate
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for libusbmuxd... yes
checking for libplist... yes
checking for libplistmm... yes

That's what I get. Weird...
Try executing "export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig" before makepkg

graysky commented on 2012-05-20 16:32

Nope :(


checking how to hardcode library paths into programs... immediate
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for libusbmuxd... no
configure: error: Package requirements (libusbmuxd >= 1.0.8) were not met:

No package 'libusbmuxd' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables libusbmuxd_CFLAGS
and libusbmuxd_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
==> ERROR: A failure occurred in build().
Aborting...

sebikul commented on 2012-05-20 14:57

Sorry, my bad. Check now please!

graysky commented on 2012-05-20 12:49

Failed to build:


configure: error: Package requirements (libusbmuxd >= 1.0.8) were not met:
No package 'libusbmuxd' found

I have usbmuxd-git 20120520-1 installed

sebikul commented on 2012-05-19 23:59

Okay, I updated usbmuxd-git and libimobiledevice-git. They build and install, but i haven't been able to test them. Can somebody confirm they are working?

graysky commented on 2012-05-19 23:12

Any solution to this error yet?

configure: error: Package requirements (libusbmuxd >= 1.0.8) were not met:

cmb commented on 2012-04-19 18:11

Nah, libimobiledevice hasn't been updated in the official repos.
1.1.1-3 is just a relink and some cosmetic changes to the PKGBILD.
In other words, it still won't work with my wife's iPhone, running iOS 5.0.

libimobiledevice-git doesn't build at present, either.
./configure dies, whining about how it wants version 1.0.8 of libusbmuxd.
There's no such version, so I tried installing usbmuxd-git, with the same
result. I bet the problem is that usbmuxd-git's files are all under
/usr/local, with libusbmuxd.pc under /usr/local/lib64/pkg-config.

akspecs commented on 2012-04-13 12:10

Any idea how long we're gonna have to wait for libplist? I tried downloading the source code myself and I couldn't get it to compile. It's my missing piece to bump myself to the current versions of these things on my own.

akspecs commented on 2012-04-13 05:44

After falling back to the official release on libimobiledevice I can no longer mount my iPhone 4S. And now for whatever reason I can't build this guy all over again either.

checking for libusbmuxd... no
configure: error: Package requirements (libusbmuxd >= 1.0.8) were not met:

Requested 'libusbmuxd >= 1.0.8' but version of libusbmuxd is 1.0.7

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables libusbmuxd_CFLAGS
and libusbmuxd_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build libimobiledevice-git.

sebikul commented on 2012-03-25 17:41

libplist PKGBUILD seems to have been updated (http://projects.archlinux.org/svntogit/packages.git/log/trunk?h=packages/libplist). We would need to wait for it's release. The libplist-git PKGBUILD is outdated and may conflict with existent libplist installations.

Also, please note that libimobiledevice has also been updated on the official repositories, so as long as no new commits are made, libimobiledevice and libimobiledevice-git share the same source code. It's highly recommended to install the official package.

Anonymous comment on 2012-03-25 09:48

The latest version seem to require 'libplist-git'.

sebikul commented on 2011-12-13 20:19

Updated GIT path on the PKGBUILD. Thanks for the fix Devan!

Anonymous comment on 2011-12-13 15:32

Need change
_gitroot="http://git.sukimashita.com/libimobiledevice.git"
TO
_gitroot="git://git.sukimashita.com/libimobiledevice.git"

In PKGBUILD

sebikul commented on 2011-11-24 19:44

I updated the PKGBUILD with Nephyrin's version. Works and builds. Tested with an iOS 5.0.1 iPhone

Da_Coynul commented on 2011-11-19 13:21

http://git.sukimashita.com/libimobiledevice.git seems to be empty so Nephyrin's PKGBUILD no longer works.

grimsbain commented on 2011-11-09 13:45

I just installed this with the pkgbuild below and it is working so far (at least in gtkpod) and everything else I have tried has failed up to this point. And as Unia said it does work with iOS5.

Unia commented on 2011-10-13 19:32

For those interested, I can confirm that this works with iOS5. I used Nephyrin's PKGBUILD

Anonymous comment on 2011-05-02 20:43

installs with PKGBUILD below from Nephyrin

Nephyrin commented on 2010-12-28 07:06

Fixed up PKGBUILD:
http://pastebin.com/QmnSLJXz

Better repo, specifies version in provides (for dependencies like gvfs-afc), and removes duplicate conflicts line.

Nephyrin commented on 2010-12-28 06:59

Why is this pointing at some random github repo?

The official repo is:
http://git.sukimashita.com/libimobiledevice.git

Linked on:
http://www.libimobiledevice.org/
(scroll down to browse git)

The repo in this pkgbuild hasn't been updated since March 15, 2010, making this pkgbuild kind of pointless.

Anonymous comment on 2010-10-31 18:28

(sorry for my english)
i'm just updated using the patch from auti
i'm test on a Virtual arch machine and works good

Anonymous comment on 2010-10-31 10:08

Hi,

I edited the PKGBUILD as per the patches (and then checked and doublechecked) but still can't build. Get the following:

http://aur.pastebin.com/PWfarBe9

Wonder what's going wrong here?

autermann commented on 2010-10-30 13:57

And: pkg-config, autoconf and libtool aren't needed as makedepends... they are in base-devel...

Overall patch: http://aur.pastebin.com/zDvSWSiz

Now i'm satisfied :D

autermann commented on 2010-10-30 13:47

libimobiledevice should also be added to the conflicts array (which is btw duplicated...)

autermann commented on 2010-10-30 13:41

I can't build the package with python3...

Also configure is already called by autogen.sh, so it should not be called again...

Patch: http://aur.pastebin.com/cLyxu8DW

kragacles commented on 2010-09-18 13:07

Just noticed that the PKGBUILD needs to add "autoconf" as a build dependency.

Anonymous comment on 2010-04-01 19:53

Fixed!!!..
Thanks for thw warning

DIDI2002 commented on 2010-04-01 19:06

git has moved to "http://github.com/mcolyer/libiphone"