Package Details: libimobiledevice-git 1:1.2.0.r52.g45fda81-2

Git Clone URL: (read-only)
Package Base: libimobiledevice-git
Description: libimobiledevice is a software library that talks the protocols to support iPhone and iPod Touch devices on Linux
Upstream URL:
Licenses: GPL2, LGPL2.1
Conflicts: libimobiledevice, libiphone, libiphone-git
Provides: libimobiledevice, libiphone, libiphone-git
Submitter: None
Maintainer: intelfx
Last Packager: intelfx
Votes: 60
Popularity: 0.800057
First Submitted: 2010-03-25 16:57
Last Updated: 2017-02-06 01:59

Required by (23)

Sources (1)

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 Next › Last »

sebikul commented on 2012-05-20 14:57

Sorry, my bad. Check now please!

graysky commented on 2012-05-20 12:49

Failed to build:

configure: error: Package requirements (libusbmuxd >= 1.0.8) were not met:
No package 'libusbmuxd' found

I have usbmuxd-git 20120520-1 installed

sebikul commented on 2012-05-19 23:59

Okay, I updated usbmuxd-git and libimobiledevice-git. They build and install, but i haven't been able to test them. Can somebody confirm they are working?

graysky commented on 2012-05-19 23:12

Any solution to this error yet?

configure: error: Package requirements (libusbmuxd >= 1.0.8) were not met:

cmb commented on 2012-04-19 18:11

Nah, libimobiledevice hasn't been updated in the official repos.
1.1.1-3 is just a relink and some cosmetic changes to the PKGBILD.
In other words, it still won't work with my wife's iPhone, running iOS 5.0.

libimobiledevice-git doesn't build at present, either.
./configure dies, whining about how it wants version 1.0.8 of libusbmuxd.
There's no such version, so I tried installing usbmuxd-git, with the same
result. I bet the problem is that usbmuxd-git's files are all under
/usr/local, with libusbmuxd.pc under /usr/local/lib64/pkg-config.

akspecs commented on 2012-04-13 12:10

Any idea how long we're gonna have to wait for libplist? I tried downloading the source code myself and I couldn't get it to compile. It's my missing piece to bump myself to the current versions of these things on my own.

akspecs commented on 2012-04-13 05:44

After falling back to the official release on libimobiledevice I can no longer mount my iPhone 4S. And now for whatever reason I can't build this guy all over again either.

checking for libusbmuxd... no
configure: error: Package requirements (libusbmuxd >= 1.0.8) were not met:

Requested 'libusbmuxd >= 1.0.8' but version of libusbmuxd is 1.0.7

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables libusbmuxd_CFLAGS
and libusbmuxd_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
==> ERROR: A failure occurred in build().
==> ERROR: Makepkg was unable to build libimobiledevice-git.

sebikul commented on 2012-03-25 17:41

libplist PKGBUILD seems to have been updated ( We would need to wait for it's release. The libplist-git PKGBUILD is outdated and may conflict with existent libplist installations.

Also, please note that libimobiledevice has also been updated on the official repositories, so as long as no new commits are made, libimobiledevice and libimobiledevice-git share the same source code. It's highly recommended to install the official package.

Anonymous comment on 2012-03-25 09:48

The latest version seem to require 'libplist-git'.

sebikul commented on 2011-12-13 20:19

Updated GIT path on the PKGBUILD. Thanks for the fix Devan!