Package Details: libimobiledevice-git 1:1.3.0.r219.g3969bc9-1

Git Clone URL: https://aur.archlinux.org/libimobiledevice-git.git (read-only, click to copy)
Package Base: libimobiledevice-git
Description: Library that talks the protocols to support iPhone and iPod Touch devices on Linux
Upstream URL: http://www.libimobiledevice.org/
Licenses: GPL2, LGPL2.1
Conflicts: libimobiledevice
Provides: libimobiledevice, libimobiledevice-1.0.so
Submitter: None
Maintainer: intelfx
Last Packager: intelfx
Votes: 69
Popularity: 0.90
First Submitted: 2010-03-25 16:57 (UTC)
Last Updated: 2024-04-03 14:38 (UTC)

Dependencies (9)

Required by (40)

Sources (1)

Latest Comments

1 2 3 4 5 6 .. 13 Next › Last »

intelfx commented on 2024-04-03 23:01 (UTC) (edited on 2024-04-03 23:02 (UTC) by intelfx)

@garywh1te I had this too, even after today's PKGBUILD update switching the makedepends from cython0 to cython.

For me, removing cython0 and installing cython fixed the issue: the AUR package now successfully builds.

I don't know if there's a way to make this AUR build "prefer" cython over cython0 if both are installed, and I don't care because I have no other package (make)depending on cython0. So maybe my solution won't fly for you, but maybe it will.

No, there is not. Side effects of of user system configuration is out of scope of AUR; users are advised to build packages in a clean chroot to avoid this issue and similar.

garywh1te commented on 2024-04-03 22:49 (UTC)

@ronjouch everything works great after today's update. Thanks to @intelfx ! Yesterday removing cython0 and installing cython did not solve the problem

ronjouch commented on 2024-04-03 22:07 (UTC)

got this error, kindly ask to fix the dependency Error: Cython version >= 3.0.0 is required. You have 0.29.37. You should look at http://www.cython.org

@garywh1te I had this too, even after today's PKGBUILD update switching the makedepends from cython0 to cython.

For me, removing cython0 and installing cython fixed the issue: the AUR package now successfully builds.

I don't know if there's a way to make this AUR build "prefer" cython over cython0 if both are installed, and I don't care because I have no other package (make)depending on cython0. So maybe my solution won't fly for you, but maybe it will.

garywh1te commented on 2024-04-02 22:26 (UTC)

got this error, kindly ask to fix the dependency

Error: Cython version >= 3.0.0 is required. You have 0.29.37. You should look at http://www.cython.org

SmashedSqwurl commented on 2024-04-02 19:22 (UTC)

I got this error trying to update to the latest build:

Error: Cython version >= 3.0.0 is required.  You have 0.29.37.  You should look at http://www.cython.org

Changing the dependency from cython0 to cython should fix it.

intelfx commented on 2023-09-27 16:29 (UTC)

Fixed. GnuTLS was used in the past to match extra/libimobiledevice. Apologies for inactivity.

HLFH commented on 2023-08-23 08:54 (UTC)

@drpr15 I have a libimobiledevice-git package ready that uses cython0 as dependency, and builds with openssl.

I only need the orphan request to be approved.
And I will happily maintain this package.

drpr15 commented on 2023-08-23 06:23 (UTC)

Building with gnutls can cause issues with larger photo databases (See https://github.com/libimobiledevice/libimobiledevice/issues/1413). Recommend switching to OpenSSL. I personally experienced the issue described in 1413, and resolved it by rebuilding with OpenSSL.

HLFH commented on 2023-08-18 22:21 (UTC)

cython0 should be added as explicit dependency as cython-git and cython do not work.