Package Details: libindicate-gtk3 12.10.1-5

Git Clone URL: https://aur.archlinux.org/libindicate.git (read-only)
Package Base: libindicate
Description: Library for raising indicators via DBus
Upstream URL: https://launchpad.net/libindicate
Licenses: LGPL
Conflicts: libindicate
Provides: libindicate
Submitter: max.bra
Maintainer: gerito
Last Packager: gerito
Votes: 73
Popularity: 0.000000
First Submitted: 2009-11-16 20:50
Last Updated: 2015-11-14 03:45

Latest Comments

SolarAquarion commented on 2017-10-19 13:38

@gerito you need to remove mono bindings

tbitai commented on 2015-09-19 18:58

Build fails with this: http://pastebin.com/nYGSAK5t

Chazza commented on 2014-04-02 10:08

I'm unflagging this package because there isn't a newer tarball on launchpad therefore it cannot be updated. If you want to fetch the latest code form launchpad, create a libindicate-bzr package instead.

City-busz commented on 2012-11-18 15:00

This library is deprecated by libmessaging-menu from the indicator-messages package. All applications that depends on libindicate should be ported to libmessaging-menu, otherwise they won't show up in the Messaging menu.

Meta bug report:
https://bugs.launchpad.net/ubuntu/+source/indicator-messages/+bug/1040259

teekay commented on 2012-05-22 19:39

Mono bindings require a "make -j1" in build() here, otherwhise it fails (with -j6) like this:

Unhandled Exception: System.IO.FileNotFoundException: Could not find file "/home/tom/abs/aur/libindicate/src/libindicate-0.6.92/bindings/mono/indicate/indicate-api.raw.pre".
File name: '/home/tom/abs/aur/libindicate/src/libindicate-0.6.92/bindings/mono/indicate/indicate-api.raw.pre'

Forcing -j1 fixes this.

Tybo commented on 2012-05-20 12:03

Libindicate requires LibXML.pm to build.

Please add perl-xml-libxml as a dependency.

Thanks a lot!

Tybo commented on 2012-05-15 08:12

I encountered the same problem as with libindicate-gtk2.

The package failed to build on my computer. It says only glib can be included directly in indicator.c. (This file includes glib and glib/gmessages)

I added the following line in the PKGBUILD just before configure and make, and now it works:

sed -i 's/#include "glib\/gmessages.h"//' libindicate/indicator.c

Tybo commented on 2012-05-15 08:08

The package failed to build on my computer. It says only glib can be included directly in indicator.c. (This file includes glib and glib/gmessages)

I added the following line in the PKGBUILD just before configure and make, and now it works:

sed -i 's/#include "glib\/gmessages.h"//' libindicate/indicator.c

Anonymous comment on 2012-04-14 21:19

https://code.launchpad.net/~ballogy/libindicate/fix-mono-location/+merge/92313

fjim commented on 2012-04-13 04:58

Same problem as @banditsan, I need it to update qutim.

All comments