Package Details: liblightdm-qt5-devel 1.15.0-1

Git Clone URL: https://aur.archlinux.org/lightdm-devel.git (read-only)
Package Base: lightdm-devel
Description: LightDM Qt client library
Upstream URL: https://launchpad.net/lightdm
Licenses: GPL3, LGPL3
Conflicts: liblightdm-qt5
Provides: liblightdm-qt5
Submitter: alucryd
Maintainer: alucryd
Last Packager: alucryd
Votes: 285
Popularity: 0.312015
First Submitted: 2013-03-14 11:18
Last Updated: 2015-06-08 09:10

Required by (0)

Sources (8)

Latest Comments

alucryd commented on 2014-06-13 23:47

Indeed, sorry about that, I shouldn't blind update packages.

padfoot commented on 2014-06-13 22:00

Need to update the patch file lightdm-default-config.patch

Line 40:
[User Accounts]
Change to:
[User List]

and update package sums for this to build correctly.

alucryd commented on 2014-01-14 08:35

padfoot: Bumped, ths for the heads up.

padfoot commented on 2014-01-14 07:23

Lightdm fails with the xorg-server-1.15.0 unless you rebuild.

Please bump package to 1.9.5-2 to force a rebuild against the new xorg.

alucryd commented on 2013-09-13 08:29

padfoot: I just fixed those perms here and in [community], for some reason mine had the right perms. I was setting them in the install file, I must have forgotten to put them back in there while transferring the line in the PKGBUILD (which was an epic fail because I used chown lightdm:lightdm instead of chown 620:620, the latter works even if the user and group do not exist).

padfoot commented on 2013-09-13 06:32

alucryd: it must have been cruft left over from previous installs in /var/cache/lightdm /var/lib/lightdm and /run/lightdm.

After uninstalling both lightdm and the greeter, ensuring the user and group were gone and deleting the above directories, upon re-installing, my ttys work as expected. I have X on tty1 and consoles on ttys 2-7. This is with 1.7.15

The only issue that needs attention is the permissions on /var/lib/lightdm
lightdm has it owned by root:root. It should be lightdm:lightdm as the gtk-greeter tries to write an .Xauthority file there as user lightdm. With root permissions on that directory, the greeter fails to start.

Cheers.

alucryd commented on 2013-09-12 09:52

padfoot: Hmm, can you try reinstalling lightdm-devel from scratch? Boot into a tty (so the lightdm user is not used), uninstall lightdm, make sure that the lightdm user is gone and that /var/lib/lightdm is gone too, then reinstall lightdm-devel?
The changes in 1.7.14 were regarding Xauthority perms.
I see that 1.7.15 is out btw, I'll update the package.

padfoot commented on 2013-09-12 09:09

Sorry for the delay. With the installing and uninstalling of various lightdm packages, the permissions on /var/lib/lightdm/.Xauthority got screwed preventing the greeter launching.

Anyway, tried lightdm from community with both lightdm-gtk2-greeter and lightdm-gtk2-greeter-devel, tty1 was X and tty2-7 were consoles.

Back to lightdm-devel and 1.7.14 displays the same issue. tty1-7 are all X.

With 1.7.12, I had minimum-vt=7 set so did not have any issues. I no longer have that package to confirm if the issue appeared with 1.7.12 or the latest 1.7.14

Cheers.

alucryd commented on 2013-09-12 08:30

I built 1.7.14, all my ttys are working as expected.

alucryd commented on 2013-09-12 08:15

padfoot: Does it also happen with lightdm from [community]? What about 1.7.12? I thought I had updated mine to 1.7.14 but didn't, and 1.7.12 works fine here, as does 1.6.1 from [community].

All comments