Package Details: liblxqt-git 1:0.17.0.2.g7fb82bc-2

Git Clone URL: https://aur.archlinux.org/liblxqt-git.git (read-only, click to copy)
Package Base: liblxqt-git
Description: Common base library for LXQt components.
Upstream URL: https://lxqt.org
Licenses: GPL, LGPL
Conflicts: liblxqt
Provides: liblxqt
Submitter: jleclanche
Maintainer: yan12125
Last Packager: lilac
Votes: 53
Popularity: 0.000023
First Submitted: 2013-10-24 00:54 (UTC)
Last Updated: 2021-05-21 17:14 (UTC)

Latest Comments

yan12125 commented on 2017-10-15 10:15 (UTC)

This package is broken as lxqt-build-tools is outdated: CMake Error at CMakeLists.txt:132 (find_package): Could not find a configuration file for package "lxqt-build-tools" that is compatible with requested version "0.4.0". The following configuration files were considered but not accepted: /usr/share/cmake/lxqt-build-tools/lxqt-build-tools-config.cmake, version: 0.3.2 Either updating lxqt-build-tools in [community] or using lxqt-build-tools-git instead solves the problem. I vote for the latter as liblxqt-git may depend on lxqt-build-tools 0.5.0 one day, before lxqt-build-tools is updated again.

ahrs commented on 2017-06-12 10:25 (UTC)

I second @tdy, Please add lxqt-build-tools as a makedepends

tdy commented on 2017-01-16 04:40 (UTC)

makedepends on lxqt-build-tools

yan12125 commented on 2016-08-03 17:09 (UTC)

Got the same error as @nbvcxz - need to install libxss. Please add libxss to depends.

nbvcxz commented on 2016-07-14 13:36 (UTC)

-- -- liblxqt version: 0.10.0 -- CMake Error: The following variables are used in this project, but they are set to NOTFOUND. Please set them or make sure they are set and tested correctly in the CMake files: X11_Xscreensaver_LIB (ADVANCED) linked by target "lxqt" in directory /tmp/aur-liblxqt-git/src/liblxqt -- Configuring incomplete, errors occurred! See also "/tmp/aur-liblxqt-git/src/build/CMakeFiles/CMakeOutput.log". Tried with yourt but also with pure makepkg. Any advice?

necopinus commented on 2015-09-12 02:38 (UTC)

@c-korn: I ran into this error two. Upgrading libqtxdg-git first resolved it.

c-korn commented on 2015-08-10 15:29 (UTC)

Octopi wants to upgrade the package somehow, but the build fails. In file included from /tmp/yaourt-tmp-korn/aur-liblxqt-git/src/liblxqt/lxqtplugininfo.cpp:29:0: /tmp/yaourt-tmp-korn/aur-liblxqt-git/src/liblxqt/lxqtplugininfo.h:40:26: schwerwiegender Fehler: XdgDesktopFile: File or directory not found.

flamusdiu commented on 2015-01-29 12:49 (UTC)

@jleclanche: I guess the build file is wrong. I get this (same as what AbaddonOrmuz gets): ==> Starting build()... -- The C compiler identification is GNU 4.9.2 -- The CXX compiler identification is GNU 4.9.2 -- Check for working C compiler: /usr/bin/cc -- Check for working C compiler: /usr/bin/cc -- works -- Detecting C compiler ABI info -- Detecting C compiler ABI info - done -- Detecting C compile features -- Detecting C compile features - done -- Check for working CXX compiler: /usr/bin/c++ -- Check for working CXX compiler: /usr/bin/c++ -- works -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Detecting CXX compile features -- Detecting CXX compile features - done CMake Error at CMakeLists.txt:136 (find_package): By not providing "FindKF5WindowSystem.cmake" in CMAKE_MODULE_PATH this project has asked CMake to find a package configuration file provided by "KF5WindowSystem", but CMake did not find one. Could not find a package configuration file provided by "KF5WindowSystem" with any of the following names: KF5WindowSystemConfig.cmake kf5windowsystem-config.cmake Add the installation prefix of "KF5WindowSystem" to CMAKE_PREFIX_PATH or set "KF5WindowSystem_DIR" to a directory containing one of the above files. If "KF5WindowSystem" provides a separate development package or SDK, be sure it has been installed. -- Configuring incomplete, errors occurred! See also "/home/pacman/pkg/liblxqt-git4589/liblxqt-git/src/build/CMakeFiles/CMakeOutput.log". ==> ERROR: A failure occurred in build(). Aborting... aura >>= Well, building `liblxqt-git` failed. aura >>= Would you like to continue anyway? [Y/n] n aura >>= Building failed.

AlfredoRamos commented on 2015-01-16 21:13 (UTC)

I can see in the CMakeLists.txt find_package(KF5WindowSystem REQUIRED QUIET) - https://github.com/lxde/liblxqt/blob/master/CMakeLists.txt#L136

jleclanche commented on 2015-01-16 21:01 (UTC)

liblxqt does not depend on kwindowsystem.

AlfredoRamos commented on 2015-01-16 20:41 (UTC)

It can't be compiled without kwindowsystem.

jleclanche commented on 2015-01-10 18:12 (UTC)

No. https://wiki.archlinux.org/index.php/PKGBUILD#makedepends

dshizzle commented on 2015-01-09 11:47 (UTC)

In order to fix this error the cmake line in the PKGBUILD has to be changed to: 'cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib "$srcdir/$_pkgname"'

argymeg commented on 2015-01-08 17:27 (UTC)

I am trying to rebuild a previously working lxqt installation after a Qt upgrade (to Qt 5.4.0) but I am getting this error during installation: error: failed to commit transaction (conflicting files) liblxqt-git: /usr/lib64 exists in filesystem Errors occurred, no packages were upgraded.

Afwas commented on 2014-12-20 18:09 (UTC)

Moving from the [lxqt-git] repository to AUR git packages (simply remove the [lxqt-git] repo in /etc/pacman.conf) I was able to built with only one change: In package liblxqt-git change the dependency from libqtxdg-git to libqtxdg-qt5-git. See: https://bbs.archlinux.org/viewtopic.php?id=191059

pmattern commented on 2014-11-25 13:25 (UTC)

Recent git versions need KF5WindowSystemConfig.cmake as provided by kwindowsystem, so I think it would make sense to add it as dependency. (Same thing may apply to different components, too, and I'm aware that some such as lxqt-notificationd-git do state it already by now. But I didn't look into this further as liblxqt is among the first components to get installed anyway.)

fenuks commented on 2014-10-16 07:54 (UTC)

@jleclanche Thank you. That did the trick.

fenuks commented on 2014-10-15 15:36 (UTC)

Can't build it. CMake Error at CMakeLists.txt:136 (find_package): By not providing "FindQt5Xdg.cmake" in CMAKE_MODULE_PATH this project has asked CMake to find a package configuration file provided by "Qt5Xdg", but CMake did not find one. Could not find a package configuration file provided by "Qt5Xdg" with any of the following names: Qt5XdgConfig.cmake qt5xdg-config.cmake Add the installation prefix of "Qt5Xdg" to CMAKE_PREFIX_PATH or set "Qt5Xdg_DIR" to a directory containing one of the above files. If "Qt5Xdg" provides a separate development package or SDK, be sure it has been installed. -- Configuring incomplete, errors occurred!

artoo commented on 2014-05-19 15:14 (UTC)

https://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines pkgver() { cd "$srcdir/repo" git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' }

artoo commented on 2014-05-19 09:06 (UTC)

In short, append either revision for version, or download source from lxqt github release page with checksum and remove git suffix.

artoo commented on 2014-05-19 08:58 (UTC)

If there was a true versioned lxqt-0.7.0, on AUR, it would create lots of confusion and troubles. Please remove 0.7.0 from all lxqt pkgnames, as you provide true git upstream packages.Or make true versioned pkgs.

stefonarch commented on 2014-05-07 20:39 (UTC)

Does not compile here: ....[100%] Building CXX object CMakeFiles/lxqt.dir/qrc_translatorsinfo.cxx.o Linking CXX shared library liblxqt.so CMakeFiles/lxqt.dir/aboutdialog/technicalinfo.cpp.o: nella funzione "LxQt::TechnicalInfo::TechnicalInfo()": technicalinfo.cpp:(.text+0x13e6): riferimento non definito a "XdgDirs::dataDirs(QString const&)" technicalinfo.cpp:(.text+0x15bc): riferimento non definito a "XdgDirs::autostartDirs(QString const&)" CMakeFiles/lxqt.dir/lxqtsettings.cpp.o: nella funzione "LxQt::LxQtThemeData::findTheme(QString const&)": lxqtsettings.cpp:(.text+0x191d): riferimento non definito a "XdgDirs::dataDirs(QString const&)" CMakeFiles/lxqt.dir/lxqtsettings.cpp.o: nella funzione "LxQt::LxQtTheme::allThemes()": lxqtsettings.cpp:(.text+0x2122): riferimento non definito a "XdgDirs::dataDirs(QString const&)" CMakeFiles/lxqt.dir/lxqttranslator.cpp.o: nella funzione "getSearchPaths()": lxqttranslator.cpp:(.text+0x13e): riferimento non definito a "XdgDirs::dataDirs(QString const&)" CMakeFiles/lxqt.dir/lxqtautostartentry.cpp.o: nella funzione "LxQt::AutostartEntry::AutostartEntry(QString const&)": lxqtautostartentry.cpp:(.text+0x38c): riferimento non definito a "XdgDirs::autostartDirs(QString const&)" collect2: error: ld returned 1 exit status CMakeFiles/lxqt.dir/build.make:1287: set di istruzioni per l'obiettivo "liblxqt.so.0.6.99" non riuscito make[2]: *** [liblxqt.so.0.6.99] Errore 1 CMakeFiles/Makefile2:63: set di istruzioni per l'obiettivo "CMakeFiles/lxqt.dir/all" non riuscito make[1]: *** [CMakeFiles/lxqt.dir/all] Errore 2 Makefile:136: set di istruzioni per l'obiettivo "all" non riuscito make: *** [all] Errore 2 ==> ERRORE: Si è verificato un errore in build(). L'operazione sta per essere interrotta...

Faerbit commented on 2014-02-10 23:41 (UTC)

Please update your dependency to "libqtxdg-git".