Package Details: libmatthew-java 0.8-5

Git Clone URL: https://aur.archlinux.org/libmatthew-java.git (read-only)
Package Base: libmatthew-java
Description: Libraries for Java: unix sockets, CGI, hexdump
Upstream URL: http://www.matthew.ath.cx/projects/java
Licenses: Expat
Replaces: matthew-java
Submitter: None
Maintainer: None
Last Packager: drevilt
Votes: 11
Popularity: 0.000000
First Submitted: 2007-10-21 15:58
Last Updated: 2015-06-08 18:40

Latest Comments

hdante commented on 2015-05-24 20:45

Didn't you miss applying sdukan's patch ?

drevilt commented on 2014-08-28 19:10

i have updated the downloadlink to a new url

drevilt commented on 2014-08-12 17:27

do you have another url where this can be downloaded?

sdukan commented on 2014-08-12 13:39

The source file can't be downloaded anymore and the ant build script fails with java 8. However it compiles and runs fine once the build script is adjusted:

<condition property="java.5.available">
<or>
<contains string="${java.version}" substring="1.5"/>
<contains string="${java.version}" substring="1.6"/>
<contains string="${java.version}" substring="1.7"/>
<contains string="${java.version}" substring="1.8"/>
</or>
</condition>
<fail message="This package requires Java 5, 6, 7 or 8." unless="java.5.available"/>

tarakbumba commented on 2013-04-06 20:44

Not building since apache-ant 1.9.0 version. Use libmatthew-java-0.8-archlinux-add-ant-1.9.patch to build:
http://pastebin.com/k000T6h2

Patch with this command: patch -p0 < libmatthew-java-0.8-archlinux-add-ant-1.9.patch

I'm flagging out-of-date until maintainer corrects this issiue in build.xml

tarakbumba commented on 2012-01-13 23:28

Not build here. "ant jars unix.h cgi.h" line should be "/usr/share/java/apache-ant/bin/ant jars unix.h cgi.h" . This way it works

ur6lad commented on 2011-07-16 06:24

0.8

ur6lad commented on 2011-04-16 21:30

Part of my build log http://pastebin.com/cN3gQYy7
Build successful.

Can you show yours log?

Anonymous comment on 2011-04-10 20:27

Needs update for correct ant path and a fix for the following error: "mv: cannot move `cx' to `src/main/java/cx': Directory not empty"

ur6lad commented on 2010-07-15 06:40

0.7.2-3:
+ fix Ant dependency's version
+ fix Makefile