Package Details: libnatspec 0.3.3-1

Git Clone URL: https://aur.archlinux.org/libnatspec.git (read-only, click to copy)
Package Base: libnatspec
Description: A collection of functions for request various charsets and locales for host system and for other system.
Upstream URL: https://github.com/Etersoft/libnatspec
Licenses: LGPL
Submitter: natrio
Maintainer: natrio
Last Packager: natrio
Votes: 19
Popularity: 0.002860
First Submitted: 2015-08-12 20:49 (UTC)
Last Updated: 2023-08-17 11:13 (UTC)

Latest Comments

Misaka13514 commented on 2024-01-28 06:05 (UTC)

Please follow Arch Linux RFC16: use SPDX license identifier in PKGBUILD.

https://gitlab.archlinux.org/archlinux/rfcs/-/blob/master/rfcs/0016-spdx-license-identifiers.rst

lav commented on 2023-08-13 21:22 (UTC)

The project is moved to github, the latest tarball URL is https://github.com/Etersoft/libnatspec/archive/refs/tags/0.3.3-alt1.tar.gz

natrio commented on 2018-03-04 10:37 (UTC) (edited on 2018-03-04 10:37 (UTC) by natrio)

Now the Surceforge is up, and all links are working.

natrio commented on 2018-03-03 09:41 (UTC) (edited on 2018-03-03 09:42 (UTC) by natrio)

It's a sourcefouge temporary problems, I think:

We're sorry -- the Sourceforge site is currently in Disaster Recovery mode. Please check back later.

The stable site's redirects are down, only mirrors works for now. Permanent relinking the package to the single mirror is not a good idea.

FadeMind commented on 2018-03-03 08:28 (UTC)

source=("https://cfhcable.dl.sourceforge.net/project/natspec/natspec/${pkgver}/${pkgname}-${pkgver}.tar.bz2") sha256sums=('678db5f2e25be3e79183ecc9ff6b19fb66775bcb6c3c962ba7716bc4a8ecce71')

kiba commented on 2018-03-02 04:30 (UTC)

sourceforge sources link now is: https://newcontinuum.dl.sourceforge.net/project/natspec/natspec/0.3.0/libnatspec-0.3.0.tar.bz2

natrio commented on 2015-10-15 17:55 (UTC)

Thanks, the "natspec" commandline tool IS depends of "popt": $ ldd /usr/bin/natspec linux-gate.so.1 (0xb7743000) libnatspec.so.0 => /usr/lib/libnatspec.so.0 (0xb76ea000) libpopt.so.0 => /usr/lib/libpopt.so.0 (0xb76dd000) libc.so.6 => /usr/lib/libc.so.6 (0xb7523000) /lib/ld-linux.so.2 (0xb7744000) But, libnatspec is NOT: $ ldd /usr/lib/libnatspec.so.0 linux-gate.so.1 (0xb77da000) libc.so.6 => /usr/lib/libc.so.6 (0xb75c7000) /usr/lib/ld-linux.so.2 (0x80076000) In result: makedepends=('popt') optdepends=('popt: natspec tool')

petronny commented on 2015-10-15 04:13 (UTC)

missing dependency: popt please add the following line to PKGBUILD: depends=('popt')