Package Details: libnautilus-extension-typeahead 46.1-1

Git Clone URL: https://aur.archlinux.org/nautilus-typeahead.git (read-only, click to copy)
Package Base: nautilus-typeahead
Description: Extension interface for Nautilus
Upstream URL: https://apps.gnome.org/Nautilus/
Keywords: files gnome nautilus typeahead
Licenses: GPL
Conflicts: libnautilus-extension, libnautilus-extension.so
Provides: libnautilus-extension, libnautilus-extension.so
Submitter: badwolfie
Maintainer: albertvaka
Last Packager: albertvaka
Votes: 45
Popularity: 0.020596
First Submitted: 2015-09-11 00:39 (UTC)
Last Updated: 2024-07-13 14:52 (UTC)

Required by (42)

Sources (1)

Latest Comments

1 2 3 4 5 6 .. 11 Next › Last »

albertvaka commented on 2024-07-13 14:53 (UTC)

Thanks for posting @empr, I added glib2-devel as a build dependency now.

empr commented on 2024-07-06 10:05 (UTC)

I had to manually install the package core/glib2-devel before this would build. I had this error:

nautilus/libnautilus-extension/meson.build:22:36: ERROR: Dependency 'glib-2.0' tool variable 'glib_mkenums' contains erroneous value: '/usr/bin/glib-mkenums'

This is a distributor issue -- please report it to your glib-2.0 provider.

A full log can be found at /home/mpr/.cache/yay/nautilus-typeahead/src/build/meson-logs/meson-log.txt ==> ERROR: A failure occurred in build(). Aborting... -> error making: nautilus-typeahead-exit status 4 -> Failed to install the following packages. Manual intervention is required: libnautilus-extension-typeahead - exit status 4

miscuser93 commented on 2024-06-10 07:58 (UTC)

thanks a lot for this, i cannot believe they removed this from the official package!

albertvaka commented on 2024-04-06 19:25 (UTC) (edited on 2024-04-06 19:26 (UTC) by albertvaka)

I would start by asking the Nautilus maintainers upstream at Gnome to re-add that feature. Only if they are against it (like they are for typeahead) we should consider maintaining an external patch for it. Having to maintain a patch like this one is a pain, I would be happier if we didn't need to do this.

Anuskuss6 commented on 2024-04-06 19:12 (UTC)

Okay, I found the issue: My files used to be sorted by "Modified — Time" but after upgrading, that option is no longer available yet the files were still sorted by something (neither alphabetical nor chronological). Re-sorting by "Modified" fixes it.

Anyway, speaking of, is there a chance that you could reintroduce "Modified — Time"? GNOME certainly loves taking features away...

albertvaka commented on 2024-04-06 11:16 (UTC)

It works for me on a 7k files directory. Does the standard nautilus package not crash?

Anuskuss6 commented on 2024-04-06 02:23 (UTC)

Crashes when inside of a big directory (>1000 files).

prurigro commented on 2024-04-05 20:45 (UTC) (edited on 2024-04-05 20:48 (UTC) by prurigro)

@artofakume: The build runs correctly for me, are you building a fresh package?

mkdir ~/temp

cd ~/temp

git clone https://aur.archlinux.org/nautilus-typeahead.git

cd nautilus-typeahead

makepkg -sr

artofakume commented on 2024-04-05 20:42 (UTC)

I just wanted to report back that the build is still broken. The error is still the same. Cheers!

artofakume commented on 2024-04-05 13:41 (UTC)

Thanks! I'll try again in a few hours and report back if the build still fails :)