Package Details: libnds 1.5.12-1

Git Clone URL: https://aur.archlinux.org/libnds.git (read-only)
Package Base: libnds
Description: Library for Nintendo DS homebrew development
Upstream URL: http://www.devkitpro.org
Licenses: custom
Submitter: Schnouki
Maintainer: carstene1ns
Last Packager: carstene1ns
Votes: 18
Popularity: 0.000647
First Submitted: 2008-04-23 03:17
Last Updated: 2015-12-13 12:32

Dependencies (3)

Required by (3)

Sources (2)

Latest Comments

carstene1ns commented on 2014-06-12 22:07

Well there is a 'default_arm7'[1] package, so I think this package should actually (opt)depend on that. Unfortunately the maintainer does not update it (I flagged it 2 months ago).
I have actually no experience with NDS homebrew, only updated the whole devkitpro stuff that was available on the AUR. I will try to get in touch and get it fixed soon.

[1]: https://aur.archlinux.org/packages/default_arm7/

alexdantas commented on 2014-06-12 13:45

When compiling any of the examples I was getting an error like:
'Cannot find /opt/devkitpro/default.elf'

So the solution was to download the default ARM7 binary here[0],
extract and copy to `$DEVKITPRO/libnds/`

Source[1]

[0]: http://sourceforge.net/projects/devkitpro/files/default%20arm7/
[1]: http://devkitpro.org/viewtopic.php?f=6&t=1695&view=previous#p3939

carstene1ns commented on 2014-04-08 20:28

Adopted and updated to latest version.

carstene1ns commented on 2014-04-08 04:07

adopted, will fix soon.

Yamakaky commented on 2014-03-02 22:50

1.5.7 out

Anonymous comment on 2011-10-12 12:37

New PKGBUILD:

# Maintainer: David El-Saig <daud.ici@gmail.com>
# Contributor: Schnouki <thomas.jost@gmail.com>
# Contributor: Vithon <ratm@archlinux.us>
# Prev. Maintainer : Gonzalo Lorca <human at vtr.net>

pkgname=libnds
pkgver=1.5.2
pkgrel=1
pkgdesc="A very useful library for Nintendo DS homebrew games development"
arch=("i686" "x86_64")
url="http://www.devkitpro.org/category/libnds/"
license=('custom')
options=("!strip")
makedepends=('devkitarm')
source=("http://downloads.sourceforge.net/sourceforge/devkitpro/$pkgname-$pkgver.tar.bz2")
md5sums=('77041ccc3337ec51f2b495c676e935b0')
build() {
cd $srcdir
mkdir -p $pkgdir/opt/devkitpro/
mv $srcdir/ $pkgdir/opt/devkitpro/libnds
rm $pkgdir/opt/devkitpro/libnds/$pkgname-$pkgver.tar.bz2
mkdir -p $pkgdir/usr/share/licenses/$pkgname
ln -s /opt/devkitpro/$pkgname/${pkgname}_license.txt $pkgdir/usr/share/licenses/$pkgname/${pkgname}_license.txt
}

Anonymous comment on 2011-07-11 10:08

There is a problem with the newest release, when you go to build anything, the compiler throws an error saying libnds9.a is incompatible. This can be fixed by adding "!strip" to the options field in the PKGBUILD. Also, 1.5.2 has been released.

Anonymous comment on 2011-07-05 09:59

Okay, sorry about that, I totally forgot about it. I updated to version 1.5.1 so it should be fine now.

Anonymous comment on 2011-03-09 15:47

1.5.0 is out

Anonymous comment on 2010-12-30 21:16

Just adopted package and updated to 1.4.8.

All comments