Package Details: libnm-iwd 1.32.0-1

Git Clone URL: (read-only, click to copy)
Package Base: networkmanager-iwd
Description: NetworkManager client library with iwd backend
Upstream URL:
Licenses: LGPL
Submitter: digitalone
Maintainer: buzo
Last Packager: buzo
Votes: 16
Popularity: 0.98
First Submitted: 2019-08-10 10:04
Last Updated: 2021-06-18 11:39

Dependencies (38)

Required by (1)

Sources (2)

Pinned Comments

digitalone commented on 2019-08-10 10:37

This is a modified package configured to get NetworkManager working exclusively with iwd. Main difference with upstream version is that iwd is required and wpa_supplicant is not needed (so you can uninstall it); iwd seems more reliable on certain wireless cards, so someone could prefer it in place of wpa_supplicant.

It's recommended to enable systemd iwd.service at boot: systemctl enable iwd.service

Tested with Plasma NM system tray applet (plasma-nm), it's working.

Note that wpa_supplicant is still needed to build the package, but you can uninstall it after the building stage.

Latest Comments

1 2 3 4 Next › Last »

maksverver commented on 2021-06-22 13:01

The mainline networkmanager package switched to provides=( and its dependants have been updated too, so it makes sense for networkmanager-iwd to do the same.

Using the name of the provided library (rather than the name of a compatible package) seems compatible with the packaging guidelines described here:

There is no rationale provided there, but I suspect the goal is to decouple library dependencies from package dependencies:

  1. Packages that work with any implementation of but don't care about which package provides it should depend only (the library can be provided by either libnm or libnm-iwd).
  2. Packages that need a particular implementation can depend on the package that provides it (e.g networkmanager-iwd must depend on libnm-iwd, because it won't work with mainline libnm).

The conclusion is that if your system is up-to-date, the official packages should already work, and for any custom PKGBUILDs or AUR packages, you should update the dependency on libnm to either (if mainline will work) or libnm-iwd (if required).

Gadgethm commented on 2021-06-22 05:27

If you change all instances of 'provides=(' and 'provides =' to 'provides=(libnm)' and 'provides = libnm' respectively in both the PKGBUILD and the .SRCINFO files, then it will properly build and install, or at least that worked for me. Will report back more if I run into problems.

Not sure why the changes in 48622efab81d got backed out... Any ideas?

frebib commented on 2021-06-21 10:06

buzo: Echoing what cubethethird said, libnm-iwd dependencies are broken again. This happened before and you fixed it in 48622efab81d. Why does this keep happening? Thanks

cubethethird commented on 2021-06-19 02:39

I can no longer install libnm-iwd as it no longer provides libnm, but instead only, and it complains that this breaks dependencies for other packages. Is there a particular reason for this change?

buzo commented on 2021-05-13 09:06

maksverver: Fixed, thanks. (Please click on “Flag package out-of-date” next time.)

maksverver commented on 2021-05-12 18:40

I had to bump ppp_version to 2.4.9 to install this, which is the current version of ppp in the core repo. Maybe a pkgrel update is in order?

Gadgethm commented on 2021-02-01 23:30

I also see the same issue as cubethethird, hopefully will be fixed in the next update.

cubethethird commented on 2021-01-17 20:57

It's looking like there's an issue with the package version (possibly 1 too many characters in the hash). When running the pkgver function, the version gets updated to 1.28.1dev+7+g3f5df3cdc-1, which is considered to be older than the stated version in the PKGBUID of 1.28.1dev+7+g3f5df3cdc6-2. As a result, each time I build and update, I am still informed that the upstream is newer than the current.

buzo commented on 2021-01-04 12:54

Thanks, frebib – fixed.

frebib commented on 2021-01-04 12:10

error: failed to prepare transaction (could not satisfy dependencies)
:: installing libnm-iwd (1.28.1dev+7+g3f5df3cdc6-1) breaks dependency 'libnm' required by blueman
:: installing libnm-iwd (1.28.1dev+7+g3f5df3cdc6-1) breaks dependency 'libnm' required by libnma
:: installing libnm-iwd (1.28.1dev+7+g3f5df3cdc6-1) breaks dependency 'libnm' required by networkmanager-openconnect
:: installing libnm-iwd (1.28.1dev+7+g3f5df3cdc6-1) breaks dependency 'libnm' required by tracker3-miners

The libnm provides needs to be re-added to the libnm-iwd package