Package Details: libopencl 2.0-3

Git Clone URL: https://aur.archlinux.org/libopencl.git (read-only)
Package Base: libopencl
Description: AMD OpenCL library and ICD loader
Upstream URL: http://developer.amd.com/tools-and-sdks/opencl-zone/amd-accelerated-parallel-processing-app-sdk/
Licenses: custom
Conflicts: libcl, nvidia-utils
Provides: libcl
Submitter: kralyk
Maintainer: None
Last Packager: kralyk
Votes: 26
Popularity: 0.000000
First Submitted: 2011-07-09 16:59
Last Updated: 2016-09-04 11:49

Dependencies (1)

Required by (22)

Sources (0)

Latest Comments

1 2 3 4 Next › Last »

JonasCz commented on 2018-12-19 15:02

For anyone getting the 404, I searched for an alternative link, eventually found this one: (checksum is the same, google the filename if this one dissapears)

http://cs.wisc.edu/~riccardo/assets/AMD-APP-SDKInstaller-v3.0.130.136-GA-linux64.tar.bz2

and then modify the PKGBUILD to use it, like this: https://gist.github.com/JonasCz/d8e1c3adf54df4d44fe7147fc266419f

Ashark commented on 2018-11-16 02:44

==> Downloading AMD APP SDK...
[nonce1] Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
https://developer.amd.com/tools-and-sdks/opencl-zone/amd-accelerated-parallel-processing-app-sdk/:
2018-11-16 05:41:52 ERROR 404: Not Found.
==> ERROR: A failure occurred in prepare().
Aborting...
==> ERROR: Makepkg was unable to build libopencl.

mausworks commented on 2018-05-16 20:17

@kjdfangipugn hit enter, that worked for me.

However, now I'm stuck on the aformentioned problem:

"install: cannot stat 'lib/x86_64/libOpenCL.so': No such file or directory", however, the AUR is flagged out of date since March 29, 2017; So I'm not expecting miracles here.

kjdfangipugn commented on 2018-01-07 17:00

Checking libopencl integrity...

==> Making package: libopencl 2.0-3 (Sun Jan 7 08:43:14 PST 2018)

==> Retrieving sources...

And there it sits, forever...

physicist1616 commented on 2017-11-02 17:06

I'm also getting the 404 @mt45 is getting.

umoveswd commented on 2017-10-27 12:29

I couldn't build the package. The error was:
==> Downloading AMD APP SDK...
[nonce1] http://developer.amd.com/tools-and-sdks/opencl-zone/amd-accelerated-parallel-processing-app-sdk/:
2017-10-27 14:56:17 ERROR 404: Not Found.

frankcoder commented on 2017-06-04 15:50

Same issues as @falrus and @jugs
I have taken a look into the source, it seems that contains an invalid symlink?
aur-libopencl/src/lib/x86_64/libOpenCL.so -> /usr/lib/libOpenC

rafaelff commented on 2017-03-29 23:01

I couldn't reproduce. Please double check that the checksum of the downloaded source tarball matches the one specified in the PKGBUILD (first one is for x86_64). Also, try cleaning up the srcdir by running makepkg with '-C' flag.

jugs commented on 2017-03-29 21:51

Same issues as @falrus, cannot make

falrus commented on 2017-02-08 12:15

Can not make package. Command makepkg finishes with:

==> Starting package()...
install: cannot stat 'lib/x86_64/libOpenCL.so': No such file or directory
==> ERROR: A failure occurred in package().
Aborting...