Package Details: libopenmpt-doc-svn 0.7.r16685-1

Git Clone URL: https://aur.archlinux.org/libopenmpt-svn.git (read-only, click to copy)
Package Base: libopenmpt-svn
Description: Library to decode tracked music files (modules) into a raw PCM audio stream (svn version)
Upstream URL: https://lib.openmpt.org/libopenmpt/
Keywords: audio libopenmpt modules openmpt123
Licenses: BSD
Conflicts: libopenmpt-doc
Provides: libopenmpt-doc
Submitter: dbermond
Maintainer: dbermond
Last Packager: dbermond
Votes: 28
Popularity: 0.74
First Submitted: 2016-07-16 01:20 (UTC)
Last Updated: 2022-01-24 17:54 (UTC)

Latest Comments

dbermond commented on 2022-03-09 17:34 (UTC)

@SamLukeYes I have no such error. I've just checked, and my pkgver was correctly updated to 0.7.r17093. AUR helpers are not supported, use makepkg.

SamLukeYes commented on 2022-03-09 17:03 (UTC)

Failed to build in paru chroot.

==> Starting pkgver()...
==> ERROR: pkgver is not allowed to contain colons, forward slashes, hyphens or whitespace.
==> ERROR: pkgver() generated an invalid version: svnversion: warning: cannot set LC_CTYPE locale
svnversion: warning: environment variable LANG is en_US.UTF-8
svnversion: warning: please check that your locale name is correct
0.7.r17093
==> ERROR: Build failed, check /var/lib/aurbuild/x86_64/yes/build

jokersus commented on 2022-01-24 23:38 (UTC)

@dbermond Thanks!

dbermond commented on 2022-01-24 17:53 (UTC)

@jokersus Package updated.

jokersus commented on 2022-01-24 12:59 (UTC)

Looks like the patch is outdated. Please update it: https://0x0.st/oo3U.patch

jdj commented on 2021-09-26 13:04 (UTC) (edited on 2021-09-26 13:04 (UTC) by jdj)

@debermond Thank you, the problem is gone. I cloned the git clone URL manually and did makepkg. This must had been some issues with AUR helpers.

dbermond commented on 2021-09-26 11:31 (UTC)

@jdj The patch applies fine for me. It looks like that you are using an existing source tree for building. Make sure to always use a clean source tree when building packages. This can be done, for example, by using the makepkg --cleanbuild/-C option.

jdj commented on 2021-09-26 02:23 (UTC)

I think 010-libopenmpt-fix-doc-install-dir.patch is now upstream? I get the following error message and makepkg fails:

==> Starting prepare()...
patching file Makefile
Reversed (or previously applied) patch detected!  Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file Makefile.rej
==> ERROR: A failure occurred in prepare().

hrehfeld commented on 2021-02-13 11:21 (UTC)

Awesome, thanks!

dbermond commented on 2021-02-12 19:36 (UTC)

@hrehfeld I've updated the package dependencies.

hrehfeld commented on 2021-02-08 16:43 (UTC)

Why is pulseaudio a required dep? This fucks up JACK systems.

dbermond commented on 2020-04-24 12:15 (UTC)

@troyBORG Sorry, but AUR helpers and Manjaro are not supported. The package is building without problems. Please use makepkg on Arch Linux and it will work fine.

troyBORG commented on 2020-04-24 07:56 (UTC)

Can't update. Getting tons of "Permission denied" errors.

Terminal Log: https://paste.ubuntu.com/p/jS5mgpjSZK/

dbermond commented on 2018-07-08 01:34 (UTC)

@codyps At the full path where you're building, is there some directory that is a simlink?

codyps commented on 2018-07-08 00:24 (UTC)

Build failure:

:: Checking libopenmpt-svn integrity...
==> Making package: libopenmpt-svn 0.2.r6870-1 (Sat Jul  7 20:22:22 2018)
==> Retrieving sources...
  -> Updating libopenmpt-svn svn repo...
Skipped '.'
svn: E155007: None of the targets are working copies
==> WARNING: Failure while updating libopenmpt-svn svn repo
==> Validating source files with sha256sums...
    libopenmpt-svn ... Skipped
:: Preparing libopenmpt-svn...
==> Making package: libopenmpt-svn 0.2.r6870-1 (Sat Jul  7 20:22:22 2018)
==> WARNING: Skipping dependency checks.
==> Retrieving sources...
  -> Updating libopenmpt-svn svn repo...
Skipped '.'
svn: E155007: None of the targets are working copies
==> WARNING: Failure while updating libopenmpt-svn svn repo
==> WARNING: Skipping all source file integrity checks.
==> Extracting sources...
  -> Creating working copy of  svn repo...
cp: cannot copy a directory, '/home/y/.cache/pacaur/libopenmpt-svn/libopenmpt-svn', into itself, '/innerpool/TMP/y/.cache/pacaur/libopenmpt-svn/libopenmpt-svn/src/libopenmpt-svn'

==> ERROR: An unknown error has occurred. Exiting...
/bin/pacaur: line 1260:  2605 User defined signal 1   makepkg -od --skipinteg ${makeopts[@]}

fitu996 commented on 2017-06-10 03:52 (UTC)

I'm confused that how often should I update it. Sometimes I forget to update some -git or -svn and it leads to compilation failure when I build other software. I have problem with downloading the source: ___________________ svn: E170013: Unable to connect to a repository at URL 'https://source.openmpt.org/svn/openmpt/trunk/OpenMPT' svn: E000110: 执行上下文错误: 连接超时 ___________________ It's seemd that my country block me from visiting some foreign website. I wonder if there is any public mirrors for it (may be github?). I cannot find anything about it.