Package Details: libpam_pwdfile 1.0-2

Git Clone URL: https://aur.archlinux.org/libpam_pwdfile.git (read-only)
Package Base: libpam_pwdfile
Description: A PAM module allowing authentication via an /etc/passwd-like file
Upstream URL: https://github.com/tiwe-de/libpam-pwdfile
Licenses: GPL
Submitter: dalu
Maintainer: dalu
Last Packager: dalu
Votes: 6
Popularity: 0.037491
First Submitted: 2015-08-12 14:32
Last Updated: 2015-08-18 10:29

Dependencies (1)

Required by (0)

Sources (1)

Latest Comments

dalu commented on 2015-08-18 10:30

@felixonmars fixed, thanks

felixonmars commented on 2015-08-18 07:36

Eh I ran diff in the reverse way. Please specify -R while applying.

felixonmars commented on 2015-08-18 05:54

Update PAM_LIB_DIR to fix it:

--- a/PKGBUILD 2015-08-18 13:52:51.141281280 +0800
+++ b/PKGBUILD 2015-08-12 22:35:02.000000000 +0800
@@ -24,6 +24,6 @@
package() {
cd "$srcdir/libpam-pwdfile-${pkgver}"

- make PAM_LIB_DIR="$pkgdir/usr/lib/security" INSTALL=$(which install) install
+ make PAM_LIB_DIR="$pkgdir/lib/security" INSTALL=$(which install) install
}

Register commented on 2015-08-18 03:18

loading packages...
resolving dependencies...
looking for conflicting packages...

Packages (1) libpam_pwdfile-1.0-1

Total Installed Size: 0.01 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring [########################################] 100%
(1/1) checking package integrity [########################################] 100%
(1/1) loading package files [########################################] 100%
(1/1) checking for file conflicts [########################################] 100%
error: failed to commit transaction (conflicting files)
libpam_pwdfile: /lib exists in filesystem
Errors occurred, no packages were upgraded.