Package Details: libpamac 11.3.1-1

Git Clone URL: https://aur.archlinux.org/libpamac.git (read-only, click to copy)
Package Base: libpamac
Description: Library for Pamac package manager based on libalpm
Upstream URL: https://gitlab.manjaro.org/applications/libpamac
Licenses: GPL3
Conflicts: libpamac-aur, libpamac-full
Submitter: FredBezies
Maintainer: None
Last Packager: FredBezies
Votes: 4
Popularity: 0.001780
First Submitted: 2021-06-09 17:07 (UTC)
Last Updated: 2022-06-08 13:08 (UTC)

Latest Comments

SaifAlSubhi commented on 2022-06-22 09:31 (UTC)

Will adding provides=('libpamac') resolve the missing dependency when installing paman?

fabiscafe commented on 2021-06-10 16:58 (UTC)

@FredBezies It still doesnt make any sense. You have to either update 2 pacman dependencies or one libalpm. there will no API change come to pacman>=6.0<6.1 so it will stay at libalpm.so=13

FredBezies commented on 2021-06-10 15:07 (UTC)

I set it this way for a simple reason. Every major release of pamac brings a new major version of alpm.

I don't have to track directly libalpm this way.

fabiscafe commented on 2021-06-10 14:38 (UTC)

@FredBezies What do you mean by simpler? 'libalpm.so=13' is a valid replacement for what you set with 'pacman>=6.0' 'pacman<6.1'. I dont know why Manjaro doesnt do this, but they might have reason. Doesnt matter here.

FredBezies commented on 2021-06-10 13:31 (UTC) (edited on 2021-06-10 13:35 (UTC) by FredBezies)

@fabis_cafe:

Using both pacman version is the simpler way to be sure right alpm is packaged.

Looking at official Manjaro PKGBUILD:

https://gitlab.manjaro.org/packages/extra/libpamac/-/blob/master/PKGBUILD

depends=('glib2' 'json-glib' 'libsoup' 'dbus-glib' 'polkit' 'appstream-glib' 'pacman>=6.0' 'pacman<6.1' 'pacman-mirrors>=4.9.1' 'git')

I will only remove provides line.

Clean up done in 11.0.0-3.

fabiscafe commented on 2021-06-10 13:14 (UTC)

@FredBezies it should depend on libalpm.so=13 rather then 'pacman>=6.0' 'pacman<6.1', provides=('libpamac') is useless.

Also

# Only for Manjaro users who should not use it...
provides=('libpamac')
# End of Manjaro users section

The AUR is for ArchLinux only.

FredBezies commented on 2021-06-09 17:08 (UTC)

Package which will be needed to support libalpm13+ with pamac-aur.

See https://gitlab.manjaro.org/applications/pamac/-/issues/1047#note_22182