Package Details: libplatform-legacy 1.0.10-2

Git Clone URL: https://aur.archlinux.org/libplatform-legacy.git (read-only)
Package Base: libplatform-legacy
Description: Platform support library used by add-ons for Kodi up to Jarvis
Upstream URL: https://github.com/Pulse-Eight/platform
Licenses: GPL
Submitter: Bevan
Maintainer: Bevan
Last Packager: Bevan
Votes: 20
Popularity: 0.007248
First Submitted: 2016-02-03 23:14
Last Updated: 2016-11-15 18:02

Latest Comments

rmast commented on 2016-08-06 21:42

Please also add 'armv6h'.

With an Mpeg-2 license this even works on a Pi1.

Bevan commented on 2016-02-24 07:17

@jmason: Thanks for the hint! I just added it.

jmason commented on 2016-02-24 04:43

I've successfully installed this package on RPi2 as required for Kodi, which also requires kodi-platform-git (https://aur.archlinux.org/packages/kodi-platform-git/). The latter PKGBUILD specifies:

arch=('armv7h' 'i686' 'x86_64')

whereas this package specifies:

arch=('i686' 'x86_64')

RPi2 is ARMv7 so I was a little surprised that it installed. Does that make sense and should "arch=" be updated to include it for clarity anyway?

Bevan commented on 2016-02-14 12:50

@ogarcia: You are right. Thanks for the hint! :)

ogarcia commented on 2016-02-14 12:43

I do several tests and I think that you can remove the libplatform conflict, cause libplatform official package is really 'libp8-platform' and you can have installed libplatform and libplatform-legacy together.