Package Details: libpng14 1.4.19-1

Git Clone URL: https://aur.archlinux.org/libpng14.git (read-only)
Package Base: libpng14
Description: A collection of routines used to create PNG format graphics files - 1.4 version
Upstream URL: http://www.libpng.org/pub/png/libpng.html
Licenses: custom
Submitter: FredBezies
Maintainer: shaggytwodope
Last Packager: shaggytwodope
Votes: 218
Popularity: 0.295202
First Submitted: 2012-01-31 07:24
Last Updated: 2015-12-18 14:39

Latest Comments

FredBezies commented on 2014-12-13 11:35

@timdaniel : libpng 1.4.14 was released on 20 november 2014 => http://sourceforge.net/projects/libpng/files/libpng14/1.4.14/

timdaniel commented on 2014-12-12 22:16

This is failing in the md5sum validation part.

FredBezies commented on 2014-05-20 07:40

Disowning because I don't use it anymore. Feel free to adopt it and keep it alive.

FredBezies commented on 2014-02-11 08:38

1.4.13-2 : full version with apng patch.

FredBezies commented on 2014-02-08 22:09

Updated to 1.4.13. Disabled apng patch for now. Will modify PKGBUILD when apng is updated.

justin8 commented on 2013-07-11 10:53

Can you please add 'armv7' to supported architectures. I can confirm it compiles.

wookietreiber commented on 2013-06-08 12:03

awesome :)

FredBezies commented on 2013-06-08 10:30

@wookietreiber : fixed :)

wookietreiber commented on 2013-06-08 10:07

namcap libpng14-1.4.12-3-x86_64.pkg.tar.xz
libpng14 E: Missing custom license directory (usr/share/licenses/libpng14)

The path should be /usr/share/licenses with 's' not 'c'. Please update.

FredBezies commented on 2013-04-09 19:19

Done. Sorry for the delay.

rafaelff commented on 2013-04-05 09:01

@FredBezies: just fyi, you should install the license file when it is not one of the commons.

FredBezies commented on 2013-01-10 08:09

Added a workaround for autoconf 1.13.x

breul99 commented on 2013-01-10 07:40

make fails to build the current version
libtoolize: You should add the contents of the following files to `aclocal.m4':
libtoolize: `/usr/share/aclocal/ltversion.m4'
libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.ac and
libtoolize: rerunning libtoolize, to keep the correct libtool macros in-tree.
libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
configure.ac:34: error: 'AM_CONFIG_HEADER': this macro is obsolete.
You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
configure.ac:34: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: error: echo failed with exit status: 1
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build libpng14.

Anonymous comment on 2012-04-27 16:25

Oh, my bad. I didn't know that. I wonder why it wasn't already on my system.

rafaelff commented on 2012-04-27 16:21

@anthan: Packages from base-devel they are assumed to be installed (read Archwiki AUR)

Anonymous comment on 2012-04-27 16:15

automake needs to be added to the dependencies list. I had to install it to get the build to work.

FredBezies commented on 2012-04-04 05:04

Upgraded to libpng 1.4.11.

FredBezies commented on 2012-03-03 20:06

Updated. Thanks.

Jristz commented on 2012-03-03 18:29

All versions of libpng from 1.0.6 through 1.5.8, 1.4.8, 1.2.46, and 1.0.56, respectively, fail to correctly validate a heap allocation in png_decompress_chunk(), which can lead to a buffer-overrun and the possibility of execution of hostile code on 32-bit systems. This serious vulnerability has been assigned ID CVE-2011-3026 and is fixed in version 1.5.9 (and versions 1.4.9, 1.2.47, and 1.0.57, respectively, on the older branches), released 18 February 2012.

Huulivoide commented on 2012-02-11 19:20

I think this could be configured not to include
the static lib....

diffycat commented on 2012-02-08 17:13

@Cleem
'base-devel' packages should not be included in makedepends arrays

Anonymous comment on 2012-02-08 17:02

add automake and autoconf as makedepends, please

FredBezies commented on 2012-02-06 09:08

@diffycat : fixed and cleaned up a little PKGBUILD. Thanks for the comment.

diffycat commented on 2012-02-06 09:03

'pkgdesc' string is broken.

FredBezies commented on 2012-01-31 07:25

Work in progress, based on libpng12 aur package. Need for example by iscan package.