Package Details: libpqmarble 1.3.0+12+gf240b2e-4

Git Clone URL: https://aur.archlinux.org/libpqmarble.git (read-only, click to copy)
Package Base: libpqmarble
Description: Utility library for GNOME apps.
Upstream URL: https://gitlab.gnome.org/raggesilver/marble
Licenses: GPL-3.0-or-later
Conflicts: libmarble
Provides: libpqmarble.so
Replaces: libmarble
Submitter: yochananmarqos
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 2
Popularity: 0.078414
First Submitted: 2023-08-10 22:20 (UTC)
Last Updated: 2024-01-20 23:49 (UTC)

Latest Comments

yochananmarqos commented on 2023-08-31 20:45 (UTC)

@brianmercer: Oh, right. vala 0.56.13-1.

brianmercer commented on 2023-08-31 17:20 (UTC) (edited on 2023-08-31 17:22 (UTC) by brianmercer)

@yochananmarqos: maybe this two days ago:

Vala 0.56.13
============
 * Bindings:
  - gtk4: Restore CssProvider.load_from_data() signature to take an array
    [#1478]

Thank you.

yochananmarqos commented on 2023-08-31 14:47 (UTC)

@brianmercer: Strange, it built fine a few days ago. I've updated the patch.

brianmercer commented on 2023-08-31 13:55 (UTC) (edited on 2023-08-31 14:25 (UTC) by brianmercer)

That new patch for debian is causing build failure for me.

https://gitlab.gnome.org/raggesilver/marble/-/issues/12

https://git.altlinux.org/gears/l/libmarblepq.git?p=libmarblepq.git;a=blob;f=.gear/libmarblepq-2.0.0-alt-css-provider-build-fix.patch;h=2cd183b4f39238a63cc8baa53dff1d952c3e4171;hb=d75fb9000e32938994be7edf133a4ddfca95f949

   35 |     provider.load_from_data (data, data.length);
      |     ^~~~~~~~~~~~~~~~~~~~~~~                     
../marble/src/utils/Utils.vala:35.30-35.33: error: Argument 1: Cannot convert from `unowned string' to `unowned uint8[]'
   35 |     provider.load_from_data (data, data.length);
      |                              ^~~~               
../marble/src/utils/Utils.vala:35.5-35.47: error: 1 extra arguments for `void Gtk.CssProvider.load_from_data (uint8[])'
   35 |     provider.load_from_data (data, data.length);

workaround: just reverting the patch works for me, but could also use alumni's line below targeting the new patch

sed -i 's/provider.load_from_data (data, data.length)/provider.load_from_string (data)/g' src/utils/Utils.vala

yochananmarqos commented on 2023-08-24 21:42 (UTC)

@alumni: Thanks!

alumni commented on 2023-08-24 20:59 (UTC)

To fix the error:

  sed -i 's/provider.load_from_data (data.data)/provider.load_from_string (data)/g' src/utils/Utils.vala

ldm commented on 2023-08-19 07:19 (UTC)

tnx @yochananmarqos I'll wait for them to fix the error...

yochananmarqos commented on 2023-08-18 19:50 (UTC)

@ldm: See https://gitlab.gnome.org/raggesilver/marble/-/issues/12

ldm commented on 2023-08-18 18:02 (UTC)

I'm trying to install blackbox-terminal but I got this libpqmarble error:

https://digilander.libero.it/luca.dm/images/libpqmarble.png

any help?