Package Details: libpurple-carbons-git r27.8ab2fe5-3

Git Clone URL: https://aur.archlinux.org/libpurple-carbons-git.git (read-only)
Package Base: libpurple-carbons-git
Description: Experimental XEP-0280: Message Carbons plugin for libpurple (Pidgin, Finch, etc.)
Upstream URL: https://github.com/gkdr/carbons
Licenses: GPL
Conflicts: libpurple-carbons
Submitter: postblue
Maintainer: None
Last Packager: postblue
Votes: 6
Popularity: 0.001158
First Submitted: 2017-02-28 13:14
Last Updated: 2018-04-28 10:59

Latest Comments

Lucki commented on 2018-04-11 18:43

The package() function fails. Replacing Line 38 with make install PURPLE_PLUGIN_DIR="$pkgdir/usr/lib/purple-2" seems to work but builds it a second time.

==> Starting package()...
cc -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -DPURPLE_PLUGINS -c ./src/carbons.c -o build/carbons.o
./src/carbons.c:20:10: fatal error: glib.h: No such file or directory
 #include <glib.h>
          ^~~~~~~~
compilation terminated.
make: *** [Makefile:53: build/carbons.o] Error 1
==> ERROR: A failure occurred in package().
    Aborting...

JustinTime4Tea commented on 2017-03-04 16:25

Please fix upstream URL. Lurch is for OMEMO support not carbons though by the same author.

Correct upstream URL is:

https://github.com/gkdr/carbons

Also though lurch is nice it is in no way a depenency (optional or not) of carbons and isn't related.