Package Details: libqtelegram-ae-git 3:10.0.0.stable.r27.g1865e02-1

Git Clone URL: https://aur.archlinux.org/libqtelegram-ae-git.git (read-only)
Package Base: libqtelegram-ae-git
Description: Telegram library written in Qt based on telegram-cli code
Upstream URL: https://github.com/Aseman-Land/libqtelegram-aseman-edition
Licenses: GPL3
Conflicts: libqtelegram-ae
Provides: libqtelegram-ae=3:10.0.0.stable.r27.g1865e02
Submitter: farseerfc
Maintainer: farseerfc (nylocx)
Last Packager: farseerfc
Votes: 4
Popularity: 0.003185
First Submitted: 2015-05-08 04:21
Last Updated: 2016-10-18 09:16

Latest Comments

farseerfc commented on 2017-08-07 06:30

@pjaeger yes, waiting for upstream to show up and fix...

pjaeger commented on 2017-08-07 05:54

Build fails because the aseman edition of libqtelegram is not compatible with openssl 1.1. Also, it seems there are some issues with recent versions of gcc, according to the open issues on github.

farseerfc commented on 2016-10-18 09:18

@svalo thanks for the fix! I have updated the PKGBUILD to include your fix.
@deriherdianto @arun_kpm sorry for the delay, it should be now fixed.

svalo commented on 2016-10-18 08:54

I was getting compile errors, edited the PKGBUILD as following

diff --git a/PKGBUILD b/PKGBUILD
index ed749b3..fedf943 100644

--- a/PKGBUILD
+++ b/PKGBUILD
@@ -50,7 +50,7 @@ build() {
qmake-qt5 -r ../libqtelegram-code-generator
make

- ./libqtelegram-generator 54 ../scheme/scheme-54.tl ..
+ ./libqtelegram-generator 57 ../scheme/scheme-57.tl ..
cd ..
## end of ./init

And it compiles

deriherdianto commented on 2016-10-17 23:23

error ???

Anonymous comment on 2016-10-16 15:28

I got compile error

http://pastebin.com/v4fiywWh

Ender commented on 2016-09-14 19:13

@farseerfc, thanks for the fix. Build sucessful now.

farseerfc commented on 2016-09-14 11:05

@Ender thanks for reporting the error. It is because the upstream set a git submodule in the ./init script but forget to update this submodule link. I have moved the commands in ./init script into build(), it should now build.

Ender commented on 2016-09-12 10:09

I've got several errors while installing the package:

http://pastebin.com/fRJQPsNq

farseerfc commented on 2016-05-13 11:58

@JZA It's the recent gcc6.1.1 broke the compatibility of qmake generated Makefile. Fixed and it should build normally now. Thanks.

All comments