Package Details: librabbitmq-c 0.8.0-2

Git Clone URL: (read-only)
Package Base: librabbitmq-c
Description: A RabbitMQ(amqp) library written in C-language
Upstream URL:
Licenses: MIT
Submitter: aleiphoenix
Maintainer: travisghansen
Last Packager: travisghansen
Votes: 5
Popularity: 0.000000
First Submitted: 2011-06-16 08:13
Last Updated: 2016-08-27 21:17

Latest Comments

travisghansen commented on 2015-10-09 00:22

Done. Thanks!

adbjesus commented on 2015-10-08 23:13

Hey, as a previous comment said the lib cannot currently compile giving the error xsl:import : unable to load

While -DBUILD_TOOLS_DOCS=OFF should work, adding docbook-xsl as a dependeny could be a better solution.

travisghansen commented on 2015-05-22 20:13

OK, try it now. I've bumped to 0.6.0 along with an updated php-amqp that works with the updated version.

cosmo0920 commented on 2015-05-22 13:01

Hi there,
I've encountered md5sums mismatch your PKGBUILD.
Could you update it?

BTW, I succeeded installation in ARMv7h version of Arch Linux system with following patch:

--- PKGBUILD.orig 2015-05-22 12:57:26.673722412 +0000
+++ PKGBUILD 2015-05-22 12:58:02.855015184 +0000
@@ -5,12 +5,12 @@ pkgname=librabbitmq-c
pkgdesc="A RabbitMQ(amqp) library written in C-language"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv7h')
makedepends=('cmake' 'python' 'xmlto' 'openssl')

build() {

travisghansen commented on 2015-02-26 21:30

OK, I'll add the definition. I'm going to wait to publish this as php-amqp fails to build against 0.6.0 currently.


daBrado commented on 2015-02-26 20:49

Oh, I think I found it... I had to set `-DCMAKE_INSTALL_LIBDIR=lib` for cmake during the setup step in the PKGBUILD's `build()` step... there is some logic in the project's `cmake/GNUInstallDirs.cmake` that makes a decision about using lib vs lib64 if `CMAKE_INSTALL_LIBDIR` isn't set explicitly.

daBrado commented on 2015-02-26 20:33

I seem to be having the same problem with CMake trying to write to /usr/lib64 instead of /usr/lib... and cannot find the right way to tell CMake to use /usr/lib instead of /usr/lib64...

travisghansen commented on 2015-01-22 22:30

That's strange. I have 64 bit machine and items are going to /usr/lib for me. In either case it seems strange that it would conflict on a basic directly like that.

I also can replicate I/O errors you're getting. Sorry :(

If you find a solution let me know and I'm happy to patch/integrate with the package.

daurnimator commented on 2015-01-22 19:32

But the second issue remains: the package puts files in /usr/lib64 instead of /usr/lib as it should. I don't know the CMake flag to fix that.

daurnimator commented on 2015-01-22 19:32

I only needed -DBUILD_TOOLS_DOCS=OFF to prevent that error.

All comments