Package Details: libreddit-git r27.c4b9400-1

Git Clone URL: https://aur.archlinux.org/libreddit-git.git (read-only, click to copy)
Package Base: libreddit-git
Description: Alternative private front-end to Reddit
Upstream URL: https://github.com/spikecodes/libreddit
Licenses: AGPL-3.0
Conflicts: libreddit
Provides: libreddit
Submitter: spikecodes
Maintainer: spikecodes
Last Packager: spikecodes
Votes: 2
Popularity: 0.048488
First Submitted: 2020-10-21 00:01
Last Updated: 2021-01-04 20:47

Required by (0)

Sources (1)

Latest Comments

somini commented on 2021-05-28 22:33

https://github.com/spikecodes/libreddit/pull/227 is merged now.

  • contrib/libreddit.conf to be installed in /etc/libreddit.conf
  • contrib/libreddit.service, to be installed in /usr/lib/systemd/system(pkg-config systemd --variable=systemd_system_unit_dir)

somini commented on 2021-05-23 12:01

@SZanko Good idea, https://github.com/spikecodes/libreddit/pull/227

SZanko commented on 2021-05-20 12:50

Please make a Pull Request with your systemd unit and hope that the developer merge your stuff into the main repo. This would also help people with are running other distros.

somini commented on 2021-03-04 01:18

This could use a systemd unit to easily run this. Here's my take:

# /etc/systemd/system/libreddit.service
[Unit]
Description=libreddit daemon
After=network.service

[Service]
DynamicUser=yes
# Default Values
Environment=ADDRESS=0.0.0.0
Environment=PORT=8080
# Optional Override
EnvironmentFile=-/etc/libreddit.conf
ExecStart=/usr/bin/libreddit -a $ADDRESS -p $PORT

[Install]
WantedBy=default.target

The /etc/libreddit.conf is optional.

# cat /etc/libreddit.conf
ADDRESS=localhost
PORT=12345

Ideally, the program could take options as environment variables directly, as defaults without arguments. Should I open a Pull Request on the repository itself, or do you prefer a patch here?


If you are running a reverse proxy in front of this (in this case nginx), use also:

# /etc/systemd/system/libreddit.service.d/reverse-proxy.conf
[Unit]
Before=nginx.service

spikecodes commented on 2021-01-04 20:48

It sounds like a default Rust toolchain hasn't been configured. Try running:

rustup install stable
rustup default stable

Tio commented on 2021-01-04 19:54

Now I get this error:

==> Starting pkgver()...
==> Updated version: libreddit-git r156.f819ad2-1
==> Starting build()...
error: no override and no default toolchain set
==> ERROR: A failure occurred in build().
    Aborting...

spikecodes commented on 2021-01-04 18:06

Not sure why it was set to the nightly toolchain. Just fixed it by switching to Rust's stable toolchain, thanks!

Tio commented on 2021-01-04 17:59

Same here. I get this error:

==> Starting pkgver()...
==> Updated version: libreddit-git r155.f5884a5-1
==> Starting build()...
error: toolchain 'nightly-x86_64-unknown-linux-gnu' is not installed
==> ERROR: A failure occurred in build().
    Aborting...

geosam commented on 2021-01-04 14:56

I get th next error:

error: toolchain 'nightly-x86_64-unknown-linux-gnu' is not installed