Package Details: librepilot-rpm 16.09-1

Git Clone URL: https://aur.archlinux.org/librepilot-rpm.git (read-only)
Package Base: librepilot-rpm
Description: A ground control station and firmware for UAV flight controllers
Upstream URL: http://www.librepilot.org
Licenses: GPL
Conflicts: librepilot
Replaces: openpilot
Submitter: juliosddr
Maintainer: juliosddr
Last Packager: juliosddr
Votes: 1
Popularity: 0.050104
First Submitted: 2019-01-22 13:35
Last Updated: 2019-01-22 17:40

Latest Comments

Scimmia commented on 2019-05-21 14:36

Why is this extracting the source a second time? makepkg already does it for you. The source file renaming is also a very bad idea, it makes updates difficult as you could still have the old source file around.

juliosddr commented on 2019-02-03 15:50

Yes, the proyect is kind of messy. I can not find the proper documentation on how to build it D:

M3gts58 commented on 2019-02-03 12:40

It seems like some dependencies need to be added to the pkgbuild. For this package to work I had to first install qt5-script. Then I ran into the error descripted below. For this I had to install openscenegraph34. Please note that the current version won't work since it would provide version 21 of libOpenThreads. After that I had to install some version of osgearth, but unfortunetaly I had to use the git version of the package, because the other version was outdated and did no build correctly. After this I got another error about some missing qt5 private api: /usr/lib64/librepilot-gcs/plugins/LibrePilot/libPfdQml.so: Cannot load library /usr/lib/librepilot-gcs/plugins/LibrePilot/libPfdQml.so: (/usr/lib/libQt5Quick.so.5: version `Qt_5.11.1_PRIVATE_API' not found (required by /usr/lib/librepilot-gcs/plugins/LibrePilot/../../libGCSOsgEarth.so.1)) But at this point I don't know if it is worth trying an older version of qt5. I hope this helps.

juliosddr commented on 2019-01-22 13:40

"/usr/lib64/librepilot-gcs/plugins/LibrePilot/libPfdQml.so: Cannot load library /usr/lib/librepilot-gcs/plugins/LibrePilot/libPfdQml.so: (libOpenThreads.so.20: cannot open shared object file: No such file or directory)"

I have no idea about how to fix this. Any ideas?