Package Details: libretro-pcsx-rearmed-git 1358.c6e7ce9-1

Git Clone URL: https://aur.archlinux.org/libretro-pcsx-rearmed-git.git (read-only)
Package Base: libretro-pcsx-rearmed-git
Description: libretro implementation of PCSX ReARMed. (PlayStation)
Upstream URL: https://github.com/libretro/pcsx_rearmed
Licenses: GPL
Groups: libretro
Conflicts: libretro-pcsx_rearmed-git
Submitter: BlackLotus89
Maintainer: cecton
Last Packager: cecton
Votes: 12
Popularity: 0.069553
First Submitted: 2015-08-14 20:17
Last Updated: 2018-05-12 17:09

Pinned Comments

cecton commented on 2018-05-12 16:54

I just adopted this package, pull requests are welcome on https://github.com/cecton/aur-libretro-pcsx-rearmed-git

Latest Comments

cecton commented on 2018-05-12 16:54

I just adopted this package, pull requests are welcome on https://github.com/cecton/aur-libretro-pcsx-rearmed-git

cecton commented on 2017-12-27 09:56

I confirm this is working with: export platform=rpi2

faergeek commented on 2017-12-23 09:51

There's no need to install info file as it's now installed by libretro-core-info package. You'd better just add dependency on libretro-core-info package and remove info file related code.

bl0ndynek commented on 2017-02-16 11:56

If you build for Raspberry Pi 3 with armv7l packets you need to add
export platform=rpi2
before make in build section

ProfessorKaos64 commented on 2016-09-15 14:30

Can you please ad "groups=('libretro')" (sans quotes) so this shows up when installing the "libretro" group package set?

joao commented on 2016-02-05 14:18

Won't build correctly for armv7 architecture (ie. raspberry pi 2)
running pcsx_rearmed_libretro.so results in:
RetroArch [ERROR] :: Error(s): /usr/lib/libretro/pcsx_rearmed_libretro.so: undefined symbol: gteNCLIP_arm
RetroArch [ERROR] :: Fatal error received in: "load_dynamic()"

my very horrible hacky solution for raspberry pi 2 only is to change PKGBUILD so the build section looks like this:
build() {
cd "${_gitname}"
export CFLAGS="-mcpu=cortex-a7 -mfpu=neon-vfpv4 -mfloat-abi=hard -O3"
export CXXFLAGS=$CFLAGS
./configure --platform=libretro
make
}

this will complete compilation with a file named libretro.so (in src/pcsx_rearmed/) but fail to build the installer package. but we only need libretro.so
so rename libretro.so to: pcsx_rearmed_libretro.so
and copy it to the libretro cores folder (usr/lib/libretro/). should work.

hissingshark commented on 2015-11-26 18:58

I built this using the ABS on an Rpi2, having just successfully built and run other libretro cores.
This appears to build ok but when run I get:
RetroArch [ERROR] :: Failed to open libretro core: "/usr/lib/libretro/pcsx_rearmed_libretro.so"
RetroArch [ERROR] :: Fatal error received in: "load_dynamic()"

Any thoughts?