Package Details: libretro-pocketsnes-git r17.79f6be5-1

Git Clone URL: https://aur.archlinux.org/libretro-pocketsnes-git.git (read-only)
Package Base: libretro-pocketsnes-git
Description: ARM based SNES emulator for libretro
Upstream URL: https://github.com/libretro/pocketsnes-libretro
Licenses: custom
Conflicts: libretro-super-git
Submitter: mfussenegger
Maintainer: firstbass
Last Packager: firstbass
Votes: 0
Popularity: 0.000000
First Submitted: 2012-10-28 07:35
Last Updated: 2015-07-16 10:35

Dependencies (1)

Required by (0)

Sources (1)

Latest Comments

ProfessorKaos64 commented on 2016-09-15 14:30

Can you please ad "groups=('libretro')" (sans quotes) so this shows up when installing the "libretro" group package set?

BlackLotus89 commented on 2016-01-02 00:07

The PKGBUILDs package function doesn't work since the lib got renamed

--- PKGBUILD.old 2016-01-02 00:03:27.668281165 +0000
+++ PKGBUILD 2016-01-02 00:03:47.418188355 +0000
@@ -28,5 +28,5 @@
package()
{
mkdir -p "$pkgdir/usr/lib/libretro"
-install -m755 "$srcdir/${_gitname}/libretro.so" "$pkgdir/usr/lib/libretro/libretro-pocketsnes.so"
+install -m755 "$srcdir/${_gitname}/pocketsnes_libretro.so" "$pkgdir/usr/lib/libretro/pocketsnes_libretro.so"
}

Also I would consider adding the info file from git

firstbass commented on 2015-07-16 10:37

@Holzhaus I have applied your PKGBUILD. If anyone would rather be the package maintainer or co-maintainer, please contact me.

mfussenegger commented on 2015-04-24 21:33

@Holzhaus I've disowned the package, feel free to adopt it and update the PKGBUILD

Holzhaus commented on 2015-04-18 16:58

There are several problems with this PKGBUILD, e.g. $arch is wrong, a pkgver()-function is not used and the git repo is cloned inside the build()-function. Here's an updated PKGBUILD that fixes the issues:
https://gist.github.com/Holzhaus/c3cca9881e35a6c3254a