Package Details: librewolf 89.0-1

Git Clone URL: https://aur.archlinux.org/librewolf.git (read-only, click to copy)
Package Base: librewolf
Description: Community-maintained fork of Firefox, focused on privacy, security and freedom.
Upstream URL: https://librewolf-community.gitlab.io/
Licenses: GPL, MPL, LGPL
Submitter: lsf
Maintainer: lsf
Last Packager: lsf
Votes: 27
Popularity: 4.28
First Submitted: 2019-06-14 18:41
Last Updated: 2021-06-04 10:41

Dependencies (38)

Sources (5)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

lsf commented on 2021-03-12 13:53

Do you mean the patch for the global menubar?

If so, that patch is still included, but not automatically applied (as it caused issues on quite a few configurations). Those might not be an issue anymore (seems like they only occurred due to another unrelated issue that's fixed by now), but that's not tested yet. It can be applied by just uncommenting the line at https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=librewolf#n153.

dr460nf1r3 commented on 2021-03-12 13:41

Is there a chance of getting the appmenu patch back?

rev.cressy commented on 2021-03-09 14:10

Since the build takes such a long time you might consider changing mkdir mozbuild in the prepare function to mkdir -p mozbuild which would not give a error if you are attempting to rebuild on error or something.

Another solution would be to include the mkdir in a if block like:

if [[ ! -d mozbuild ]]; then mkdir mozbuild fi

just an idea :-)

rev.cressy commented on 2021-03-09 13:57

Is there a way to save the geometry on exit like firefox?

peryngveohlin666 commented on 2021-02-26 19:34

@lsf: doing a clean build fixed it for me, I had the same problem on a previous version so just assumed the shasums weren't updated.

lsf commented on 2021-02-26 16:42

@peryngveohlin666: works on my end. you might want to check if you still have some files from a previous build lying around (in the folder you're running makepkg, or in the caches of yay/paru/etc.).

peryngveohlin666 commented on 2021-02-26 16:36

==> Validating source_x86_64 files with sha256sums... firefox-86.0.source.tar.xz ... Passed librewolf.desktop ... Passed common ... Skipped settings ... Skipped megabar.patch ... FAILED remove_addons.patch ... Passed context-menu.patch ... Passed unity-menubar.patch ... Passed ==> ERROR: One or more files did not pass the validity check!

cladonia commented on 2021-02-15 23:21

Thank you, it works.

It was this glibc update.

saloniamatteo commented on 2021-02-15 21:46

@cladonia: musl is a C standard library, just like glibc. No, you do not need to install it, but you need to upgrade glibc to >= 2.33

https://archlinux.org/packages/core/x86_64/glibc/

cladonia commented on 2021-02-15 21:43

Hello,

I have 2.32-5 version of glibc

I have no musl installed (and didn't know its existence or what it is). I can install it.