Package Details: libs76-hidpi-widget-git r17.a66eb84-1

Git Clone URL: (read-only, click to copy)
Package Base: libs76-hidpi-widget-git
Description: System76 HiDPI daemon widget library
Upstream URL:
Keywords: System76
Licenses: GPL3
Conflicts: libs76-hidpi-widget
Provides: libs76-hidpi-widget
Submitter: yochananmarqos
Maintainer: None
Last Packager: yochananmarqos
Votes: 0
Popularity: 0.000000
First Submitted: 2020-11-28 20:41 (UTC)
Last Updated: 2023-03-04 01:40 (UTC)

Latest Comments

yochananmarqos commented on 2022-02-01 03:43 (UTC)

@postblue: Upstream updated a dependency, it's building again.

yochananmarqos commented on 2022-01-28 23:43 (UTC)

@postblue: The upstream dependencies need to be updated, apparently. No idea why you're even bothering building this package as the only thing it could possibly be used for is gnome-control-center-system76. I haven't included it as a dependency in a long time. The patches need to be adapted, for one.

postblue commented on 2022-01-26 09:11 (UTC)

I have an error and cannot compile the package:

error: failed to select a version for `cairo-sys-rs`.
    ... required by package `gdk-sys v0.14.0`
    ... which satisfies dependency `ffi = "^0.14.0"` of package `gdk v0.14.0`
    ... which satisfies dependency `gdk = "^0.14"` of package `gtk-extras v0.3.0 (`
    ... which satisfies git dependency `gtk-extras` of package `hidpi-widget v0.1.1 (/home/postblue/Projets/libs76-hidpi-widget-git/src/hidpi-widget)`
    ... which satisfies path dependency `hidpi-widget` of package `ffi v0.1.1 (/home/postblue/Projets/libs76-hidpi-widget-git/src/hidpi-widget/ffi)`
versions that meet the requirements `^0.14.0` are: 0.14.9, 0.14.0

the package `cairo-sys-rs` links to the native library `cairo`, but it conflicts with a previous package which links to `cairo` as well:
package `cairo-sys-rs v0.10.0`
    ... which satisfies dependency `cairo-sys-rs = "^0.10.0"` of package `cairo-rs v0.9.1`
    ... which satisfies dependency `cairo-rs = "^0.9.0"` of package `gtk v0.9.2`
    ... which satisfies dependency `gtk = "^0.9.0"` of package `ffi v0.1.1 (/home/postblue/Projets/libs76-hidpi-widget-git/src/hidpi-widget/ffi)`
Only one package in the dependency graph may specify the same links value. This helps ensure that only one copy of a native library is linked in the final binary. Try to adjust your dependencies so that only one package uses the links ='cairo-sys-rs' value. For more information, see

failed to select a version for `cairo-sys-rs` which could resolve this conflict