Package Details: libsafec 30122018-2

Git Clone URL: https://aur.archlinux.org/libsafec.git (read-only)
Package Base: libsafec
Description: Implementtion of C11 Annex K + ISO TR24731 Bounds Checking Interface
Upstream URL: https://rurban.github.io/safeclib
Keywords: c11 library
Licenses: MIT
Submitter: jetm
Maintainer: jetm
Last Packager: jetm
Votes: 1
Popularity: 0.000018
First Submitted: 2017-08-30 23:55
Last Updated: 2019-01-30 21:14

Latest Comments

jetm commented on 2019-01-30 21:14

@jrmrjnck: Yeah, it seems that is the case. I have looked, but unable to find which dependency is missing. Meanwhile, I submitted a workaround, so the package will install without this issue.

jrmrjnck commented on 2019-01-30 20:23

I still see the error on a totally fresh install with a totally fresh user account, with only these packages installed: "base base-devel sudo vim ndctl intel-ucode wget openssh git clang". Possibly there is an unspecified dependency leading to the error.

jetm commented on 2018-12-21 03:06

@jrmrjnck: I don't get that error.

$ atool -l libsafec-03032018-1-x86_64.pkg.tar.xz 2> /dev/null | grep towlower

-rw-r--r-- root/root 43 2018-12-20 20:56 usr/share/man/man3/towlower_s.3.gz

That file gets moved to towlower_s because there is another towlower file.

You might clean your build environment and start over.

jrmrjnck commented on 2018-12-20 17:31

I get this error when compiling: mv: cannot stat '/.../libsafec/pkg/libsafec/usr/share/man/man3/towlower.3': No such file or directory

Looks like the man pages are not getting installed by the upstream makefile anymore?