Package Details: libsearpc 1:3.0.8-2

Git Clone URL: (read-only)
Package Base: libsearpc
Description: A simple and easy-to-use C language RPC framework (including both server side & client side) based on GObject System.
Upstream URL:
Licenses: Apache
Submitter: aclindsa
Maintainer: eolianoe (thealchemist, Joffrey)
Last Packager: eolianoe
Votes: 75
Popularity: 1.472966
First Submitted: 2013-01-19 15:50
Last Updated: 2017-03-17 19:36

Latest Comments

eolianoe commented on 2017-09-03 14:55

@akhfa & @craftyguy: pkg-config should be already installed as it's from the base-devel group which is an implicit requirement [a]


akhfa commented on 2017-09-03 13:47

@craftyguy You need to install pkg-config first.

I don't now how to contribute to aur so I can't add to dependencies.

hillbicks commented on 2017-01-05 18:04

correct sha256sum for libsearpc-v3.1-latest.tar.gz:

5chdn commented on 2016-12-26 19:43

Validating source files with sha256sums...
libsearpc-v3.1-latest.tar.gz ... FAILED
libsearpc.pc.patch ... Passed
ERROR: One or more files did not pass the validity check!

eolianoe commented on 2016-12-20 14:29

@craftyguy: I cannot reproduce this failure, do you have all the dependencies properly installed?

craftyguy commented on 2016-12-19 02:31

Fails when in configure:

checking for WIN32... checking for Mac... ./configure: line 11970: syntax error near unexpected token `GLIB,'
./configure: line 11970: `PKG_CHECK_MODULES(GLIB, gobject-2.0 >= $GLIB_REQUIRED)'
==> ERROR: A failure occurred in build().
:: failed to build libsearpc package(s)

noEntry commented on 2016-12-17 12:11

Deleting the cache worked. Never had such a problem...

alexanderp commented on 2016-12-15 07:19

You've probably got the old version cached: delete ~/.cache/pacaur/libsearpc

eolianoe commented on 2016-12-14 19:52

@noEntry: are you sure that you are using the latest PKGBUILD and source ?

noEntry commented on 2016-12-14 19:14

Issue persists:

==> Validating source_x86_64 files with sha256sums...
flash_player_ppapi_linux_24.0.0.186.x86_64.tar.gz ... Passed
:: Checking libsearpc integrity...
==> Making package: libsearpc 3.1-2 (Mi 14. Dez 20:12:20 CET 2016)
==> Retrieving sources...
-> Found libsearpc-v3.1-latest.tar.gz
-> Found libsearpc.pc.patch
==> Validating source files with sha256sums...
libsearpc-v3.1-latest.tar.gz ... FAILED

eolianoe commented on 2016-12-14 12:35

@languitar & @jaltek: should be fixed in 3.1-2

languitar commented on 2016-12-13 17:17

Same issue with the validation here

jaltek commented on 2016-12-13 07:48


the integrity check for "libsearpc-v3.1-latest.tar.gz" actually fails. Maybe they changed the source file?

simontunnat commented on 2015-10-29 16:24

Could someone please take over the seafile packages as maintainer.
I just can't find the time to maintain them.

calrama commented on 2015-09-29 12:49

I am unwilling to wait any longer, so the package is now orphaned. I advise anyone willing to pick this up to pick up the whole seafile dependency tree, as it would otherwise become tedious to maintain.

calrama commented on 2015-09-05 15:38

This is the last package update from me. Since I have received mail from one from person interested in maintaining, I will not orphan the packages just yet, but in the next couple of days.

muellerd commented on 2015-08-26 17:13


python2 needs to be added to Dependencies, without the build will fail.

muellerd commented on 2015-08-26 17:13


python2 needs to be added to Dependencies, else the build will fail-

calrama commented on 2015-08-07 19:01

Since I no longer intend to use distributions with systemd for personal use,
I will abandon this package no earlier than 2015-09-01.
Should someone be interested in maintaining this package afterwards,
he or she can contact me in the interim to become co-maintainer
and then sole maintainer once I leave, to ensure a smooth transition.
If possible, I would like to hand over the following packages over to a single maintainer, since they comprise a dependency graph:
libevhtp-seafile, libsearpc, ccnet, seafile-shared, seafile-client, seafile-client-cli, seafile-server

somniumAeternam commented on 2015-07-31 12:41

autoconf is required, otherwise the build will fail

vahit commented on 2015-07-29 07:26

Hi everyone
today wheen i try install this package, i get this error:
==> ERROR: libsearpc.pc.patch was not found in the build directory and is not a URL.
what's the problem and how can i resolve it?
I need this package!

calrama commented on 2015-06-12 09:34

Initial AUR4 import.

calrama commented on 2015-01-31 18:53

@SplitFire: The package has no issues building since 2015-01-24, so I have no idea what your problem is.

calrama commented on 2015-01-31 18:51

@SplitFire: The has no issues building since 2015-01-24, so I have no idea what your problem is.

SplitFire commented on 2015-01-31 10:47

Can someone take care of this package? I think that calrama not handle this package.

senorsmile commented on 2015-01-19 05:06

as already mentioned, there's an error building this.
needs to be
to be valid bash.

mlq commented on 2014-12-19 12:42

option must not be empty if given

rumpelsepp commented on 2014-06-25 05:35

Please rebuild with mkaurball. thanks!

calrama commented on 2014-05-03 07:29

@guilhas: No, they are not. Please read [1] and then look at the members of [2]. This has been discussed in the comments here repeatedly, please read them for further information.


guilhas commented on 2014-05-02 22:37

same as maurice

pkg-config and patch missing

rudygotya commented on 2014-04-25 18:56

Misses 'libtool' dependency:


**Error**: You must have `libtool' installed to compile libsearpc.
(or a newer version if it is available)

aclindsa commented on 2014-04-12 02:53

I have orphaned this package and other seafile dependencies because I haven't used them for quite some time and no longer have the time or motivation to properly maintain them. I have not been able to find a maintainer to take over, but trust that if the package is truly useful someone will take over where I left off.

aclindsa commented on 2014-04-12 02:24

I added the pacman requirement when pacman 4.1 was just being released, because it changed the behavior of the prepare() function in an incompatible way and this seemed the best way to ensure users were using a version compatible with the package. It can probably be removed now. In this case, I don't believe python2 is necessary to have as a requirement as it is implicit in the requirement of python2-simplejson.

pulb commented on 2014-04-11 18:23

Why does this package depend on pacman? Please also add python2 to the dependency list.

aclindsa commented on 2014-03-26 11:14

Thijxx: Which "instructions from the creators" did you follow? Are you saying that my unmodified package built and installed fine when using makepkg directly instead of an AUR helper, or that you had to make changes to it?

Thijxx commented on 2014-03-26 07:28

I followed the instructions from the creators. Finally it was installed in a breeze just using makepkg and pacman -U. Afterwards I could use yaourt to install the rest of seafile-client. Had to initiate the applet by hand, hope it sticks after reboot.

aclindsa commented on 2014-03-26 00:42

Thijxx: I have never seen your error, and am unable to reproduce it on any of my Arch boxes. I can't find a line in my generated ./configure script that looks like the error message you're reporting. If you identify the issue, let me know and I'll gladly update the package.

As a sidenote, I see the "./configure: line 11470: test: =: unary operator expected" warning on my side, but it appears to be harmless.

Thijxx commented on 2014-03-26 00:10

After ./ then in ./configure there is this error:

checking for WIN32... checking for Mac... ./configure: line 11449: test: =: unary operator expected
./configure: line 11474: syntax error near unexpected token `GLIB,'
./configure: line 11474: `PKG_CHECK_MODULES(GLIB, gobject-2.0 >= $GLIB_REQUIRED)'

All dependencies installed; pkg-config patch libtool glib2 jansson pacman base-devel

Tried on two machines, same result.

uname -a
Linux archbeast 3.13.7-1-ARCH #1 SMP PREEMPT Mon Mar 24 20:06:08 CET 2014 x86_64 GNU/Linux

aclindsa commented on 2014-02-02 15:27

@maurice Please read the comment immediately preceding yours.

maurice commented on 2014-02-02 14:23

Some dependencies seem to be missing: pkg-config, patch, libtool.

aclindsa commented on 2013-08-11 12:56

RobertGatstein: According to the PKGBUILD and AUR documentation[1, 2], it is assumed that the base-devel[3] group is installed, so it should not to be included in the makedepends= line. The base-devel group includes all the packages you listed.

Hope this helps!


Anonymous comment on 2013-08-11 10:08

I've had a problem to compile it on my Raspberrry
My machine had no "patch, gcc, pkg-config"
Would it possible to add this to the depends list.

kevincox commented on 2013-07-20 03:46

I noticed you added armv7h. Would it be possible to add armv6h as well. I have tested it and it works.

kevincox commented on 2013-07-04 01:11

Adding "armv6h" to the "arch" variable allows for use on arm devices such as the raspberry pi.

aclindsa commented on 2013-04-05 14:37

peplin: Ah, I hadn't updated in a few days and hadn't gotten the pacman 4.1 update yet. I'll update the packages.

peplin commented on 2013-04-05 14:21

Follow to the previous comment - prepare is now called automatically in pacman >= 4.1.

peplin commented on 2013-04-05 14:20

The call to prepare() at the top of build() is causing problems because the patch is applied twice. The second time it detects that it's already been applied and you're either given the option to reverse the patch (bad) or skip it, which causes the entire install to fail.

aclindsa commented on 2013-04-04 18:08

Are you doing anything different than downloading the tarball, extracting it, and running makepkg? (If you're installing it with pacaur/yaourt/something can you try doing it manually with makepkg to see if you can reproduce the problem that way?)

aclindsa commented on 2013-04-04 18:06

hobarrera: Interesting - I have never seen that happen before and can't reproduce it now. I'm having trouble thinking of anything that would cause this.

WhyNotHugo commented on 2013-04-04 17:49

Oh, I thought the patch was no longer needed since it looks like it's already applied upstream:

==> Starting build()...
patching file
Reversed (or previously applied) patch detected! Assume -R? [n]

aclindsa commented on 2013-04-04 11:51

hobarrera: After looking into it, the patch *is* necessary. Without it, auto-configuration does not work properly for packages which have build requirements on libsearpc (i.e. those build scripts will look for header files at the build path, not the installed path).

aclindsa commented on 2013-04-04 11:50

hobarrera: After looking into it, the patch *is* necessary. Without it, auto-configuration does not work properly for packages which have build requirements on libsearpc (i.e. those build scripts will look for header files at the build path, not the installed path).

aclindsa commented on 2013-04-04 11:19

hobarrera: Unfortunately, the developers do not seem to keep download links for older source versions around (if you have found where they do, please let me know).

Hmmm, it does appear to work fine without the patch now. I seem to remember an earlier issue where it wouldn't install to the right directory if I didn't patch up that file due to wonkiness with their build scripts.

WhyNotHugo commented on 2013-04-04 10:56

patch does not seem to be necessary.

WhyNotHugo commented on 2013-04-04 10:53

You shouldn't point to file "-latest" for this package, but rather to the proper version. Otherwise the package breaks when upstream releases a new version.