Package Details: libsemanage 3.4-1

Git Clone URL: https://aur.archlinux.org/libsemanage.git (read-only, click to copy)
Package Base: libsemanage
Description: SELinux binary policy manipulation library
Upstream URL: https://github.com/SELinuxProject/selinux
Keywords: selinux
Licenses: LGPL2.1
Conflicts: selinux-usr-libsemanage
Provides: selinux-usr-libsemanage
Submitter: Siosm
Maintainer: IooNag
Last Packager: IooNag
Votes: 22
Popularity: 0.31
First Submitted: 2013-11-03 20:05 (UTC)
Last Updated: 2022-05-29 11:39 (UTC)

Latest Comments

Araeos commented on 2015-08-04 21:58 (UTC)

Reinstalling ustr from source (ABS) with the settings source=("$pkgname-$pkgver::git+https://github.com/fishilico/ustr.git") md5sums=(SKIP) works. Also this package is missing dependencies python2 (fails if missing) and swig.

IooNag commented on 2015-05-30 03:22 (UTC)

libsemanage no longer builds with ustr 1.0.4-4 and gcc 5.1.0-4 because the linker does not like the "extern inline" syntax ustr is using. To fix this, I am currently testing two patches for ustr, available on https://github.com/fishilico/ustr/commits/master . If you succeed in building ustr and libsemanage with these patches (ustr 1.0.4-4 doesn't build from source otherwise), feel free to report a bug with the patches I've written, to ustr upstream (http://www.and.org/ustr/) or to Arch bug tracker.

Siosm commented on 2014-01-02 21:47 (UTC)

Renamed to libsemanage