Package Details: libsigrokdecode-git 0.2.0.r1038.g30d27bd-1

Git Clone URL: https://aur.archlinux.org/libsigrokdecode-git.git (read-only, click to copy)
Package Base: libsigrokdecode-git
Description: Client software that supports various hardware logic analyzers, protocol decoders library (git version)
Upstream URL: http://www.sigrok.org/wiki/Libsigrokdecode
Licenses: GPL3
Conflicts: libsigrokdecode
Provides: libsigrokdecode
Submitter: Manouchehri
Maintainer: codyps
Last Packager: codyps
Votes: 10
Popularity: 0.002014
First Submitted: 2015-09-08 21:58 (UTC)
Last Updated: 2019-01-04 21:46 (UTC)

Latest Comments

Harm commented on 2021-12-16 10:06 (UTC)

I got errors like /usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../lib/libsigrokdecode.so: undefined reference to `_Py_Dealloc' when building Pulseview.

I had to patch the configure.ac file in libsigrokdecode and added [python-3.10-embed] to the list on line 103.

codyps commented on 2018-11-03 18:32 (UTC)

Needs patch to avoid "unreleased" version number

From da922ab59f44c1541b5ac4b125fdff2ae5ac56fc Mon Sep 17 00:00:00 2001
From: Cody P Schafer <dev@codyps.com>
Date: Sat, 3 Nov 2018 14:31:17 -0400
Subject: [PATCH] avoid "unreleased"

---
 .SRCINFO | 4 +---
 PKGBUILD | 4 ++--
 2 files changed, 3 insertions(+), 5 deletions(-)

diff --git a/.SRCINFO b/.SRCINFO
index fbdf4dc..3d28b68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Mar 18 17:28:41 UTC 2017
 pkgbase = libsigrokdecode-git
    pkgdesc = Client software that supports various hardware logic analyzers, protocol decoders library (git version)
-   pkgver = 0.2.0.r716.gb26c713
+   pkgver = 0.2.0.r1030.gbe760e5
    pkgrel = 1
    url = http://www.sigrok.org/wiki/Libsigrokdecode
    arch = armv6h
diff --git a/PKGBUILD b/PKGBUILD
index b59b378..2cfb8bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@

 _gitname='libsigrokdecode'
 pkgname="${_gitname}-git"
-pkgver=0.2.0.r716.gb26c713
+pkgver=0.2.0.r1030.gbe760e5
 pkgrel=1
 pkgdesc="Client software that supports various hardware logic analyzers, protocol decoders library (git version)"
 arch=('armv6h' 'armv7h' 'i686' 'x86_64')
@@ -19,7 +19,7 @@ sha512sums=('SKIP')

 pkgver() {
   cd "${srcdir}/${_gitname}"
-  git describe --long | sed 's/^libsigrokdecode-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+  git describe --exclude 'libsigrokdecode-unreleased' --long | sed 's/^libsigrokdecode-//;s/\([^-]*-g\)/r\1/;s/-/./g'
 }

 build() {
-- 
2.19.1