Package Details: libsixel 1.10.3-4

Git Clone URL: https://aur.archlinux.org/libsixel.git (read-only, click to copy)
Package Base: libsixel
Description: provides a codec for DEC SIXEL graphics, and some converter programs
Upstream URL: https://github.com/libsixel/libsixel
Licenses: MIT
Submitter: BrainDamage
Maintainer: BrainDamage
Last Packager: BrainDamage
Votes: 26
Popularity: 1.09
First Submitted: 2016-10-04 17:39 (UTC)
Last Updated: 2021-12-13 15:58 (UTC)

Latest Comments

BrainDamage commented on 2021-11-17 19:48 (UTC) (edited on 2021-11-17 19:48 (UTC) by BrainDamage)

unfortunately, replacing that string ( which has to be edited to python2 since the latest release still doesn't support python3 ) does not fix my build under meson 0.60.1

code used to test:

prepare()
{
    sed -i 's/\(python[[:digit:]]\)installation/\1_dep/' "${srcdir}/${pkgname}-${pkgver}/meson.build"
}

sl1pkn07 commented on 2021-11-15 17:26 (UTC)

please add this patch

https://github.com/libsixel/libsixel/commit/02f591105a6276c10ad23a1bbe82e03b2bc03c00 for fix the @9@ error

BrainDamage commented on 2021-11-06 02:53 (UTC) (edited on 2021-11-06 02:54 (UTC) by BrainDamage)

To everyone having build issues wrt meson, as per here downgrading your meson version temporarily to 0.59 can workaround the problem, or wait for a new meson release

nesk_aur commented on 2021-11-04 05:45 (UTC)

Getting the "Format placeholder @9@ out of range" error as well, building from upstream archive (without makepkg), submitted an issue here: https://github.com/libsixel/libsixel/issues/50

nesk_aur commented on 2021-11-04 05:22 (UTC)

According to this libbsd is no longer a dependency of libsixel: https://github.com/libsixel/libsixel/issues/32

RubenKelevra commented on 2021-10-25 20:44 (UTC)

I can't build it on my system

Configuring sixel.h using configuration
Program bash found: YES (/usr/bin/bash)
libsixel-1.10.1/converters/meson.build:23: WARNING: Note: tests currently require the Bourne-Again Shell (bash)
Configuring libsixel-config using configuration
libsixel-1.10.1/meson.build:203: WARNING: Perl, PHP and Ruby modules are available but not installed by Meson. If you want them, please refer to their individual installation directories for instructions after building libsixel.

libsixel-1.10.1/meson.build:205:0: ERROR: Format placeholder @9@ out of range.

xdavidwu commented on 2021-09-18 12:44 (UTC)

libbsd needs to be in depends.

Message: Not on BSD, checking for libbsd.so
libsixel-1.10.1/meson.build:22:2: ERROR: C shared or static library 'bsd' not found

fbrennan commented on 2021-06-09 17:15 (UTC)

Hello,

I'm writing to encourage you to begin considering libsixel/libsixel the upstream. @saitoha has been MIA for over a year. This version is owned by a GitHub organization so less prone to one person wandering off.

See https://github.com/saitoha/libsixel/issues/154.