Package Details: libsquish 1.15-2

Git Clone URL: https://aur.archlinux.org/libsquish.git (read-only, click to copy)
Package Base: libsquish
Description: DXT compression library
Upstream URL: https://sourceforge.net/projects/libsquish/
Licenses: MIT
Submitter: None
Maintainer: ducakar
Last Packager: ducakar
Votes: 27
Popularity: 0.000000
First Submitted: 2009-09-02 20:08 (UTC)
Last Updated: 2021-03-23 22:41 (UTC)

Latest Comments

1 2 Next › Last »

ducakar commented on 2021-10-04 07:29 (UTC)

@xyproto: I don't mind. Go ahead.

xyproto commented on 2021-10-01 18:31 (UTC)

Hi, would you mind if I adopt and move this package to [community]? I believe it could be used by godot.

ducakar commented on 2016-05-07 19:13 (UTC)

You're right. Fixed.

Popkornium18 commented on 2016-05-06 09:04 (UTC)

I think this is missing the 'cmake' dependency. I got an error when installing this ("Command not found: cmake"). After installing cmake it worked fine.

Schala commented on 2015-04-13 09:45 (UTC)

AFTER calling make, of course

Schala commented on 2015-04-13 09:44 (UTC)

Here's a dirty trick to make a shared lib, provided you're in $srcdir/squish-$pkgver: g++ -shared *.o -o libsquish.so

yuan_modu commented on 2014-07-06 17:39 (UTC)

Hello, You should add options=('staticlibs') to PKGBUILD otherwise libsquish.a is deleted while packaging.

commented on 2011-05-25 19:30 (UTC)

You might want to use http://projects.archlinux.org/svntogit/community.git/tree/libsquish/trunk/Makefile to get a dynamic and static lib out of it. Simple change, no extra builddep and then it can be used for panda again :) Do note i didn't test the makefile, but as the versions are the same, i guess it should just work. (and there's not that much to it anyway)