Package Details: libunique 1.1.6-8

Git Clone URL: https://aur.archlinux.org/libunique.git (read-only, click to copy)
Package Base: libunique
Description: Library for writing single instance applications for GTK3
Upstream URL: https://wiki.gnome.org/Attic/LibUnique
Keywords: gtk
Licenses: GPL
Submitter: LeSnake
Maintainer: LeSnake
Last Packager: LeSnake
Votes: 2
Popularity: 0.31
First Submitted: 2021-07-21 21:56
Last Updated: 2021-08-10 13:01

Pinned Comments

LeSnake commented on 2021-07-27 12:52

Fixed package, sorry for the basic mistake. (I forgot to include the package function, beacause i am dumbass)

Regarding the 2 packges: the -8 one is the downloaded one. But since this isnt a normal repo, i cant just pass it directly (as far as i know at least), so i have to repack it. Thats the (currently) -10 version and the one that gets installed. (The package doesnt have a -bin suffix, since all the previosly broken specifically relied on libunique)

Also, Compiling libunique is a big challange today, since the package uses outdated calls, so it cant be compiled with modern compilers (or maybe there an flag for that, but i dont know anythig about compiler flags).

Latest Comments

mrpg commented on 2021-07-28 08:42

Thanks, works!

LeSnake commented on 2021-07-27 12:52

Fixed package, sorry for the basic mistake. (I forgot to include the package function, beacause i am dumbass)

Regarding the 2 packges: the -8 one is the downloaded one. But since this isnt a normal repo, i cant just pass it directly (as far as i know at least), so i have to repack it. Thats the (currently) -10 version and the one that gets installed. (The package doesnt have a -bin suffix, since all the previosly broken specifically relied on libunique)

Also, Compiling libunique is a big challange today, since the package uses outdated calls, so it cant be compiled with modern compilers (or maybe there an flag for that, but i dont know anythig about compiler flags).

LeSnake commented on 2021-07-26 17:56

I just realised what went wrong, but dont have the time to fix it right now. will try my best to fix it asap, but i am on travel, so its gonna take a few days

mrpg commented on 2021-07-26 12:46

Building this actually spits out two packages: libunique-1.1.6-8-x86_64.pkg.tar.zst and libunique-1.1.6-9-x86_64.pkg.tar.zst (note the difference in pkgrel). pacman -U libunique-1.1.6-8-x86_64.pkg.tar.zst works and does in fact install something, whereas the pkgrel 9 one is empty. So I'm guessing pkgrel should be set to 8?