Package Details: libva-intel-driver-g45-h264 1:2.3.0-1

Git Clone URL: https://aur.archlinux.org/libva-intel-driver-g45-h264.git (read-only)
Package Base: libva-intel-driver-g45-h264
Description: Video Acceleration (VA) API for Linux
Upstream URL: https://01.org/linuxmedia/vaapi
Licenses: MIT
Conflicts: intel-gpu-tools, libva-intel-driver
Provides: libva-intel-driver
Replaces: libva-intel-driver
Submitter: pedromj
Maintainer: pedromj (alium)
Last Packager: alium
Votes: 60
Popularity: 0.998189
First Submitted: 2014-08-04 02:05
Last Updated: 2018-12-28 10:50

Required by (22)

Sources (1)

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 13 14 Next › Last »

pedromj commented on 2013-07-02 12:28

Updated package. Please test it and report any problem. Thank you.

stativ commented on 2013-07-02 10:26

trapanator: I just did a simple test, where I first checked the output of "vainfo" and then I tried to play a file that is encoded in h264 using "mplayer -vo vaapi file.mp4"

alium commented on 2013-07-02 10:21

@stativ:
Thanks.
Yes, the G45-h264 branch is now fixed, we switch to it (intel-driver-g45-h264-20130702-2.tar.gz)

andrea76 commented on 2013-07-02 10:17

@stativ: how do you test your card with these libs?

stativ commented on 2013-07-02 09:24

alium: I did a quick test of commit 4568e24f0382d2d03215bcaf78eb0eae68f88ae5 and it seems to work fine on my GMA 4500MHD.

pedromj commented on 2013-07-01 12:00

Uploaded the updated package. Please, test it and give us feedback as @alium mentioned. Thank you.

alium commented on 2013-07-01 11:48

Works anyone update from http://cgit.freedesktop.org/vaapi/intel-driver/log/?h=g45-h264?

Please test, i need feedback!

alium commented on 2013-07-01 10:46

('a8dbe9fb92b3ccc6f1718121a6f168614cdbe7814cea8a65fe19283b82b8d78d') is correct, that should work.

[alois@lenovo libva-driver-intel-g45-h264]$ vainfo
libva info: VA-API version 0.34.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_34
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.34 (libva 1.2.1)
vainfo: Driver version: Intel i965 driver - 1.2.1.pre1
vainfo: Supported profile and entrypoints
VAProfileMPEG2Simple : VAEntrypointVLD
VAProfileMPEG2Main : VAEntrypointVLD
VAProfileH264Baseline : VAEntrypointVLD
VAProfileH264Main : VAEntrypointVLD
VAProfileH264High : VAEntrypointVLD

pedromj commented on 2013-07-01 10:43

It still does not work and I tried what you said. The SHA256 sums differ from the ones you posted. Please, point me to the source package you used to get the hash:

sha256sums=('f391d8fa2e109295d722ae7ba3f069dc6dba0c8d7c23549d4b7e35542f1f8bed')

or send it to me (pedromj@gmail.com) because the file I get from the following URL:

https://downloads.sourceforge.net/project/g45h264/intel-driver-g45-h264-20130701.tar.gz

has the following hash:

sha256sums=('a8dbe9fb92b3ccc6f1718121a6f168614cdbe7814cea8a65fe19283b82b8d78d')

so I wonder where is the file you have used.

Thank you.

alium commented on 2013-07-01 10:18

@ pedromj,
uninstall libva-driver-intel-g45-h264 and install again, firsttime, i has same problem.

[alois@lenovo ~]$ vainfo
libva info: VA-API version 0.34.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_34
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.34 (libva 1.2.1)
vainfo: Driver version: Intel i965 driver - 1.2.1.pre1
vainfo: Supported profile and entrypoints
VAProfileMPEG2Simple : VAEntrypointVLD
VAProfileMPEG2Main : VAEntrypointVLD
VAProfileH264Baseline : VAEntrypointVLD
VAProfileH264Main : VAEntrypointVLD
VAProfileH264High : VAEntrypointVLD