Package Details: libva-xvba-driver 0.8.0-6

Git Clone URL: https://aur.archlinux.org/libva-xvba-driver.git (read-only)
Package Base: libva-xvba-driver
Description: XvBA backend for VA-API
Upstream URL: https://freedesktop.org/wiki/Software/vaapi/
Licenses: GPL
Conflicts: xvba-video
Submitter: lukpod
Maintainer: lukpod
Last Packager: lukpod
Votes: 14
Popularity: 0.205510
First Submitted: 2013-08-10 19:18
Last Updated: 2016-02-17 18:39

Latest Comments

meZee commented on 2016-01-31 12:46

The opensuse.org source links are down, luckily archive.org has a mirror.

Here is a working pkgbuild, http://pastebin.com/ad4TdyiU

CoRePuLsE commented on 2015-04-09 12:21

fixes.patch's link is down.
I managed to find a cached version of it and reuploaded it to mega:
https://mega.co.nz/#!IRshiZKa!WIowjwX4rJEE-5pGOjC_uD0eukW4b7f3FMvoqKu5E1s
for ref.

CoRePuLsE commented on 2015-04-09 11:46

fixes.patch returns a 404 not found.
was it removed?

Freso commented on 2014-12-25 23:04

What's the difference between this and Vi0L0's xvba-video: https://aur.archlinux.org/packages/xvba-video ?

mid-kid commented on 2014-05-30 08:53

The build fails for me, it can't find shaders/Evergreen_mix_1.h
http://chunk.io/f/f0a947dcf6fd453d9cbc945fc4d4375a

holunder commented on 2014-03-06 16:02

@lukpod Thank you! Works!

lukpod commented on 2014-03-05 21:58

I think you have to update xvba-sdk first (manually).

holunder commented on 2014-03-04 15:44

I get
configure: error: you need XvBA to build this package
catalyst-utils 14.2-1 from Vi0L0's repository is installed (not from AUR). Any idea?

rmds commented on 2013-12-30 08:30

i have a problem:
"Validating source files with sha256sums...
lano1106_xvba_bug950_workaround.patch ... FAILED
xvba-driver-0.8.0.tar.xz ... Passed
xvba-video-0.8.0-glx-fix.patch ... Passed
xvba-video-h264-level51.patch ... Passed
fixes.patch ... Passed
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build libva-xvba-driver."

Vi0L0 commented on 2013-12-04 19:52

Olivier Langlois aka lano1106 did write the patch [1] which is a workaround for the bug that he found and reported [2].
(please note that this patch version is a little bigger from the one that he proposed on the bug report)
This workaround has fixed (vaapi accelerated) vlc on my hd 7850, it's working fine now with catalyst 13.11 beta 9.4 & xorg-server 1.14.4
Unfortunatelly it looks like it's not working with every radeon, but still i would like to propose it.

patch -Np1 < ../lano1106_xvba_bug950_workaround.patch

[1] http://catalyst.wirephire.com/files/patches/lano1106_xvba_bug950_workaround.patch
[2] http://ati.cchtml.com/show_bug.cgi?id=950

All comments