Package Details: libxcb-git 1.16.r5.g3c94601-1

Git Clone URL: https://aur.archlinux.org/libxcb-git.git (read-only, click to copy)
Package Base: libxcb-git
Description: X11 client-side library
Upstream URL: https://gitlab.freedesktop.org/xorg/lib/libxcb
Licenses: X11
Conflicts: libxcb
Provides: libxcb
Submitter: amezin
Maintainer: xiota
Last Packager: xiota
Votes: 5
Popularity: 0.000000
First Submitted: 2015-08-11 14:10 (UTC)
Last Updated: 2023-11-15 09:11 (UTC)

Required by (885)

Sources (1)

Latest Comments

shoober420 commented on 2020-09-28 13:27 (UTC)

The makedepends= section needs updated to reflect libpthread-stubs no longer being needed.

https://github.com/archlinux/svntogit-packages/blob/packages/libxcb/trunk/PKGBUILD

Also, --with-doxygen=no needs to be added to the build options, or else the package is 40MBs instead of 3.7MB.

shoober420 commented on 2020-09-20 17:35 (UTC) (edited on 2020-09-20 17:39 (UTC) by shoober420)

I have an up to date PKGBUILD ready to upload and will adopt this package.

flying-sheep commented on 2017-04-07 07:46 (UTC)

i adoped it and did the changes ed0c suggested

xuiqzy commented on 2017-01-02 06:07 (UTC)

==> Starting prepare()... patching file configure.ac Hunk #1 FAILED at 43. 1 out of 1 hunk FAILED -- saving rejects to file configure.ac.rej ==> ERROR: A failure occurred in prepare(). Aborting...

ed0c commented on 2016-09-08 00:23 (UTC)

Please - remove the patch line - add xorg-util-macros libpthread-stubs as builddeps Thanks

shoober420 commented on 2016-03-04 19:20 (UTC) (edited on 2016-03-04 19:21 (UTC) by shoober420)

I get this error message when trying to build TabError: inconsistent use of tabs and spaces in indentation Makefile:1289: recipe for target 'xproto.c' failed make[1]: *** [proto.c] Error 1 make[1]: Leaving directory ~/Downloads/packages/libxcb-git/src/libxcb/src Makefile:786: recipte for target 'all-recursive' failed make: *** [all-recursive] Error 1 ERROR: A failure occured in build().