Package Details: libxfce4ui-devel 4.17.6-1

Git Clone URL: https://aur.archlinux.org/libxfce4ui-devel.git (read-only, click to copy)
Package Base: libxfce4ui-devel
Description: Commonly used Xfce widgets among Xfce applications (Development version)
Upstream URL: https://gitlab.xfce.org/xfce/libxfce4ui/-/blob/master/README
Licenses: GPL2
Conflicts: libxfce4ui
Provides: libxfce4ui
Submitter: twa022
Maintainer: twa022
Last Packager: twa022
Votes: 15
Popularity: 0.89
First Submitted: 2013-10-27 19:35 (UTC)
Last Updated: 2022-03-31 22:50 (UTC)

Required by (56)

Sources (1)

Pinned Comments

twa022 commented on 2020-12-26 13:28 (UTC)

Don't flag out of date. This follows development snapshots. Will update once packages in the 4.17 series are published (use the stable packages in extra/community until then).

Latest Comments

lpilz commented on 2022-03-16 22:05 (UTC)

Unfortunately, the build doesn't work for me since 4.17.4-1. Something seems to be wrong with giscanner. Is anyone else experiencing this?

File "/usr/lib/gobject-introspection/giscanner/sourcescanner.py", line 34, in <module>
    from giscanner._giscanner import SourceScanner as CSourceScanner
ModuleNotFoundError: No module named 'giscanner._giscanner'

bittin commented on 2022-02-21 22:08 (UTC)

PKGBUILD for 7.17.4: https://pastebin.com/PUeEg2VC

bittin commented on 2021-12-26 22:59 (UTC)

PKGBUILD for 4.17.3: https://pastebin.com/a27UWVZj

bittin commented on 2021-09-07 07:49 (UTC)

PKGBUILD for 4.17.1: https://pastebin.com/L4sDaDSW

twa022 commented on 2020-12-26 13:28 (UTC)

Don't flag out of date. This follows development snapshots. Will update once packages in the 4.17 series are published (use the stable packages in extra/community until then).

jonathon commented on 2020-08-25 13:55 (UTC) (edited on 2020-08-28 10:47 (UTC) by jonathon)

@twa022, cool, thank you!

On another note, there's a bug in 4.15.3 which prevents keyboard shortcuts from being edited [1]. There's a small patch available [2].

twa022 commented on 2020-08-24 23:51 (UTC)

@jonathon: libxfce4ui as of now only requires libxfce4util 4.12.0 (https://git.xfce.org/xfce/libxfce4ui/tree/configure.ac.in). I'll add the versioned dependency on xfce4-{panel,appfinder}-devel

jonathon commented on 2020-08-22 16:08 (UTC) (edited on 2020-08-22 16:10 (UTC) by jonathon)

Should the dep on libxfce4util have a version dependency ('libxfce4util>=4.15.2')? It would fix build failures on xfce4-panel-devel and xfce4-appfinder-devel.

xoan commented on 2020-06-25 20:45 (UTC)

xfce4-dev-tools is required when maintainer-mode is enabled:

https://gitlab.xfce.org/xfce/libxfce4ui/-/blob/master/xfce4-about/Makefile.am#L55

  GEN about-dialog-ui.h
/bin/sh: xdt-csource: command not found
make[2]: *** [Makefile:888: about-dialog-ui.h] Error 127

accensi commented on 2019-12-16 16:18 (UTC)

Error making pkg: make[3]: *** No rule to make target 'libxfce4ui-2.deps', needed by 'libxfce4ui-2.vapi'. Stop.

enihcam commented on 2019-07-06 03:02 (UTC)

Is it possible to add '--disable-gtk2' into build?

graysky commented on 2019-05-27 17:12 (UTC)

@twa022 - You gotta add xfce4-dev-tools as a makedeps as @xdavidwu said or else the build fails.

xdavidwu commented on 2019-05-19 03:21 (UTC) (edited on 2019-05-19 03:22 (UTC) by xdavidwu)

missing makedepends xfce4-dev-tools for xdt-csource

Making all in xfce4-about
  GEN      about-dialog-ui.h
/bin/sh: xdt-csource: command not found
make[2]: *** [Makefile:868: about-dialog-ui.h] Error 127
make[1]: *** [Makefile:542: all-recursive] Error 1
make: *** [Makefile:474: all] Error 2

Skunnyk commented on 2018-09-11 11:05 (UTC)

@jackrandom yes 4.13.4 is broken with --enable-maintainer-mode switch. For now you can remove the switch from the pkgbuild.

niv commented on 2018-09-09 19:08 (UTC)

for me, its broken since 4.13.4-2: make[2]: *** No rule to make target 'libxfce4ui-dialog-ui.ui', needed by 'libxfce4ui-resources.c'. Stop

@twa022 can you compile the pkg?

alexkubica commented on 2018-05-23 06:31 (UTC) (edited on 2018-05-23 06:31 (UTC) by alexkubica)

Could install only after installing libxfce4util-devel.

tbeckerson commented on 2018-01-21 16:20 (UTC) (edited on 2018-01-21 16:20 (UTC) by tbeckerson)

Hi! I don't know if anyone noticed this before: I tried installing this package on a new Arch install that didn't have XFCE already. It error'd out with this:

libtool: warning: relinking 'libxfce4uiglade2.la'

<snip>libtool install command</snip>

/usr/bin/ld: cannot find -lxfce4ui-2

collect2: error: ld returned 1 exit status

libtool: error: error: relink 'libxfce4uiglade2.la' with the above command before installing it

Since the error says it couldn't find -lxfce4ui-2, I tried installing libxfce4ui-4.12 from the official repos. Then, this package installs fine.

sph commented on 2017-07-23 05:01 (UTC)

won't build with 4.12 libxfce4util anymore ("couldn't find libxfce4util-1.0.gir"), please add version constraint >=4.13

killermoehre commented on 2014-08-21 21:00 (UTC)

@Alad Because Xfce 4.12 (and therefore 4.11 as dev release) is all about porting from GTK2 to GTK3.

Alad commented on 2014-07-24 18:39 (UTC)

Why does this have forced GTK3 support, while libxfce4ui has not?

colinkeenan commented on 2014-02-25 01:42 (UTC)

Thanks killermoehre and twa022 for getting this fix in. I was able to transition without issue today. Took me a while to look at this again and see it was fixed.

killermoehre commented on 2014-02-19 19:03 (UTC)

Please add to the provide list "${_pkgname}-4.11" for easy transition. Thank you.

colinkeenan commented on 2014-02-16 19:42 (UTC)

How to I switch from libxfce4ui-4.11 to libxfce4ui-devel now that libxfce4ui-4.11 is no longer in AUR? I tried yaourt -S libxfce4ui and answered "y" to remove libxfce4ui-4.11, but that failed because other stuff depends on it. So, I tried removing all the xfce 4.11 stuff, but I still couldn't remove libxfce4ui-4.11 because lots of other stuff depends on it. So, how do I switch packages?