Package Details: libxfce4ui-devel 4.13.7-1

Git Clone URL: https://aur.archlinux.org/libxfce4ui-devel.git (read-only)
Package Base: libxfce4ui-devel
Description: Commonly used Xfce widgets among Xfce applications (Development version)
Upstream URL: https://git.xfce.org/xfce/libxfce4ui/tree/README
Licenses: GPL2
Groups: xfce4-devel
Conflicts: libxfce4ui
Provides: libxfce4ui=4.13.7
Submitter: twa022
Maintainer: twa022
Last Packager: twa022
Votes: 13
Popularity: 0.099517
First Submitted: 2013-10-27 19:35
Last Updated: 2019-07-31 01:22

Required by (46)

Sources (1)

Latest Comments

1 2 Next › Last »

twa022 commented on 2019-08-13 03:11

With release of xfce4 4.14 and related components this package won't be updated until new development snapshots become available (probably with 4.15.x release cycle). Please don't flag for deletion or out of date (unless there is a new development release).

enihcam commented on 2019-07-06 03:02

Is it possible to add '--disable-gtk2' into build?

graysky commented on 2019-05-27 17:12

@twa022 - You gotta add xfce4-dev-tools as a makedeps as @xdavidwu said or else the build fails.

xdavidwu commented on 2019-05-19 03:21

missing makedepends xfce4-dev-tools for xdt-csource

Making all in xfce4-about
  GEN      about-dialog-ui.h
/bin/sh: xdt-csource: command not found
make[2]: *** [Makefile:868: about-dialog-ui.h] Error 127
make[1]: *** [Makefile:542: all-recursive] Error 1
make: *** [Makefile:474: all] Error 2

Skunnyk commented on 2018-09-11 11:05

@jackrandom yes 4.13.4 is broken with --enable-maintainer-mode switch. For now you can remove the switch from the pkgbuild.

jackrandom commented on 2018-09-09 19:08

for me, its broken since 4.13.4-2: make[2]: *** No rule to make target 'libxfce4ui-dialog-ui.ui', needed by 'libxfce4ui-resources.c'. Stop

@twa022 can you compile the pkg?

ak-il commented on 2018-05-23 06:31

Could install only after installing libxfce4util-devel.

tbeckerson commented on 2018-01-21 16:20

Hi! I don't know if anyone noticed this before: I tried installing this package on a new Arch install that didn't have XFCE already. It error'd out with this:

libtool: warning: relinking 'libxfce4uiglade2.la'

<snip>libtool install command</snip>

/usr/bin/ld: cannot find -lxfce4ui-2

collect2: error: ld returned 1 exit status

libtool: error: error: relink 'libxfce4uiglade2.la' with the above command before installing it

Since the error says it couldn't find -lxfce4ui-2, I tried installing libxfce4ui-4.12 from the official repos. Then, this package installs fine.

sph commented on 2017-07-23 05:01

won't build with 4.12 libxfce4util anymore ("couldn't find libxfce4util-1.0.gir"), please add version constraint >=4.13

killermoehre commented on 2014-08-21 21:00

@Alad
Because Xfce 4.12 (and therefore 4.11 as dev release) is all about porting from GTK2 to GTK3.