Package Details: libxfce4ui-devel 4.13.4-1

Git Clone URL: https://aur.archlinux.org/libxfce4ui-devel.git (read-only)
Package Base: libxfce4ui-devel
Description: Commonly used Xfce widgets among Xfce applications (Development version)
Upstream URL: https://git.xfce.org/xfce/libxfce4ui/tree/README
Licenses: GPL2
Conflicts: libxfce4ui
Provides: libxfce4ui=4.13.4
Submitter: twa022
Maintainer: twa022
Last Packager: twa022
Votes: 12
Popularity: 0.002832
First Submitted: 2013-10-27 19:35
Last Updated: 2017-12-16 18:21

Required by (46)

Sources (1)

Latest Comments

tbeckerson commented on 2018-01-21 16:20

Hi! I don't know if anyone noticed this before: I tried installing this package on a new Arch install that didn't have XFCE already. It error'd out with this:

libtool: warning: relinking 'libxfce4uiglade2.la'

<snip>libtool install command</snip>

/usr/bin/ld: cannot find -lxfce4ui-2

collect2: error: ld returned 1 exit status

libtool: error: error: relink 'libxfce4uiglade2.la' with the above command before installing it

Since the error says it couldn't find -lxfce4ui-2, I tried installing libxfce4ui-4.12 from the official repos. Then, this package installs fine.

sph commented on 2017-07-23 05:01

won't build with 4.12 libxfce4util anymore ("couldn't find libxfce4util-1.0.gir"), please add version constraint >=4.13

killermoehre commented on 2014-08-21 21:00

@Alad
Because Xfce 4.12 (and therefore 4.11 as dev release) is all about porting from GTK2 to GTK3.

Alad commented on 2014-07-24 18:39

Why does this have forced GTK3 support, while libxfce4ui has not?

colinkeenan commented on 2014-02-25 01:42

Thanks killermoehre and twa022 for getting this fix in. I was able to transition without issue today. Took me a while to look at this again and see it was fixed.

colinkeenan commented on 2014-02-25 01:41

Thanks killermoehre for getting this fix in. I was able to transition without issue today. Took me a while to look at this again and see it was fixed.

colinkeenan commented on 2014-02-25 01:36

Thanks killermoehre. Took me a while to get around to this. For anyone else, the process to transition from ...-4.11 to ...-devel is to answer Y to edit PKGBUILD and change the following line:

provides=("${_pkgname}=${pkgver}")

to

provides=("${_pkgname}=${pkgver}" "${_pkgname}-4.11")

then continue with the install.

Of course, the maintainer of this package needs to make that change to the PKGBUILD, but since it's been a while without the fix, if you run into a problem with the transition, this is how to fix it yourself.

killermoehre commented on 2014-02-19 19:03

Please add to the provide list "${_pkgname}-4.11" for easy transition.
Thank you.

colinkeenan commented on 2014-02-16 19:42

How to I switch from libxfce4ui-4.11 to libxfce4ui-devel now that libxfce4ui-4.11 is no longer in AUR? I tried yaourt -S libxfce4ui and answered "y" to remove libxfce4ui-4.11, but that failed because other stuff depends on it. So, I tried removing all the xfce 4.11 stuff, but I still couldn't remove libxfce4ui-4.11 because lots of other stuff depends on it. So, how do I switch packages?