Package Details: light-locker-settings 1.5.4-1

Git Clone URL: https://aur.archlinux.org/light-locker-settings.git (read-only, click to copy)
Package Base: light-locker-settings
Description: A simple GUI configuration utility for light-locker
Upstream URL: https://github.com/Froggo8311/light-locker-settings
Licenses: GPL
Submitter: mellich
Maintainer: mellich
Last Packager: mellich
Votes: 5
Popularity: 0.000296
First Submitted: 2017-01-17 21:51 (UTC)
Last Updated: 2023-02-10 09:45 (UTC)

Latest Comments

mellich commented on 2023-02-10 09:49 (UTC)

I updated the package to 1.5.4. Please check if it now works for you.

Zoddo commented on 2023-02-05 22:07 (UTC)

Shouldn't the main package light-locker-settings be switched to this repository, instead of making a new package?

beast64 commented on 2023-02-05 14:26 (UTC)

Hi I launch from the command line and I got this error

/usr/share/light-locker-settings/light-locker-settings/light-locker-settings.py:31: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '4.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, GLib, Gio
Traceback (most recent call last):
  File "/usr/share/light-locker-settings/light-locker-settings/light-locker-settings.py", line 707, in <module>
    main = LightLockerSettings()
  File "/usr/share/light-locker-settings/light-locker-settings/light-locker-settings.py", line 61, in __init__
    self.builder.add_from_file(glade_file)
gi.repository.GLib.GError: gtk-builder-error-quark: /usr/share/light-locker-settings/light-locker-settings/light-locker-settings.glade:8:75 Invalid signal 'delete-event' for type 'GtkWindow' (12)

can you help me with?

Thanks

amakovec commented on 2021-04-20 12:57 (UTC)

python-gobject was required as a dependency on my machine

mellich commented on 2017-10-04 21:39 (UTC)

Thanks, updated the PKGBUILD accordingly. Right, I think at the time I wrote this PKGBUILD there was no release, yet.

jonathon commented on 2017-10-03 19:59 (UTC) (edited on 2017-10-03 19:59 (UTC) by jonathon)

I've put together a fixed-up PKGBUILD: https://bpaste.net/show/2bb7a96ca54f

hzu commented on 2017-09-27 19:42 (UTC) (edited on 2017-09-27 19:48 (UTC) by hzu)

Using "master" archive download is a really bad idea. Dependency "intltool" is also not specified.