Package Details: lightdm-bzr r2117-1

Git Clone URL: https://aur.archlinux.org/lightdm-bzr.git (read-only)
Package Base: lightdm-bzr
Description: A lightweight display manager
Upstream URL: https://launchpad.net/lightdm
Licenses: GPL3, LGPL3
Conflicts: lightdm
Provides: lightdm
Submitter: pisuka
Maintainer: alucryd
Last Packager: alucryd
Votes: 18
Popularity: 0.335256
First Submitted: 2011-05-10 00:24
Last Updated: 2015-06-08 09:10

Required by (29)

Sources (8)

  • bzr+lp:lightdm
  • lightdm-autologin.pam
  • lightdm-default-config.patch
  • lightdm.pam
  • lightdm.rules
  • lightdm.service
  • lightdm.tmpfiles
  • Xsession

Latest Comments

alucryd commented on 2015-01-26 08:22

Thx for the heads up, upstream now uses the same paths as we do :)

wchouser3 commented on 2015-01-23 18:35

I'm getting the following error, and the package won't build:

patching file data/lightdm.conf
Reversed (or previously applied) patch detected! Skipping patch.
2 out of 2 hunks ignored -- saving rejects to file data/lightdm.conf.rej
patching file data/users.conf
Reversed (or previously applied) patch detected! Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file data/users.conf.rej
==> ERROR: A failure occurred in prepare().
Aborting...
==> ERROR: Makepkg was unable to build lightdm-bzr.
==> Restart building lightdm-bzr ? [y/N]

alucryd commented on 2014-05-02 07:56

Land_oR: Thx for the report. I took this opportunity to bring the PKGBUILD up to speed with the regular and devel ones.

Land_oR commented on 2014-05-01 21:45

Hi,
lightdm-default-config.patch doesn't work atm.
This one worked for me:
http://pastebin.com/Y2UqzuZ0

alucryd commented on 2013-04-16 07:35

applebloom: Thx! I've updated the package.

applebloom commented on 2013-04-16 00:43

Logind support was added in rev. 1641, so the patch "lightdm-1.5.1-systemd_login1_power.patch" is no longer needed.

Anonymous comment on 2013-04-14 14:29

this wont compile for me, I have qt5-base installed but compilation fails saying it can't find a qt5 installation...

alucryd commented on 2013-03-20 14:30

Package update: changed lightdm home to /var/lib/lightdm so that things like last selected user are remembered across reboots. You'll need to either remove and reinstall lightdm or modify the user yourself: 'sudo usermod -d /var/lib/lightdm lightdm'.

Jristz commented on 2012-12-14 15:44

http://pkgs.fedoraproject.org/cgit/lightdm.git/tree/
If factible use the fedora patch for systemd-logind support?....or is on upstream now??

Blender commented on 2012-09-09 17:38

Could you enable introspection? It breaks LightDM's Python bindings.

eworm commented on 2012-04-06 12:40

Hm, I get the same error... Will look at that later.

I suppose this could be related to the gcc update to 4.7.0. Did you change anything between the manual checkout and building the AUR package?

Anonymous comment on 2012-04-05 18:31

When I do a manual checkout from lp:lightdm, compiling works fine. If I use the AUR package compiling fails. I have tested the parameters for configure.

CC Xvnc-x-authority.o
In file included from /usr/include/unistd.h:1171:0,
from libsystem.c:8:
libsystem.c: In function 'pam_setcred':
/usr/include/bits/unistd.h:266:1: error: inlining failed in call to always_inline 'getgroups': function not inlinable
libsystem.c:879:27: error: called from here
In file included from /usr/include/unistd.h:1171:0,
from libsystem.c:8:
/usr/include/bits/unistd.h:266:1: error: inlining failed in call to always_inline 'getgroups': function not inlinable
libsystem.c:881:27: error: called from here
make[3]: *** [libsystem_la-libsystem.lo] Error 1

eworm commented on 2012-03-15 12:22

@Huulivoide:
I have !libtool in my OPTIONS array in /etc/make.conf.
Any reason why to overwrite this in PKGBUILD instead of letting the user decide via system settings?

Huulivoide commented on 2012-03-15 11:29

You should add !libtool to options=() array
to remove libtool .la files from the pkg

eworm commented on 2012-03-07 08:54

@Teho:
Please do not flag out-of-date bzr packages. The package automatically builds with the latest version from bazaar repository.

falconindy commented on 2012-03-04 00:58

Well, trunk finally supports invoking PAM correctly (meaning it "works" with systemd). the environment is still nowhere near setup properly, though.

Anonymous comment on 2012-02-26 15:14

When I use lightdm with systemd my session of LXDE doesn't start (black screen), I have to and restart lightdm with '/etc/rc.d/lightdm restart' to make it work.

Anyone knows what happen?

Anonymous comment on 2011-10-15 16:27

How to build lightdm-bzr without gnome?

pisuka commented on 2011-10-13 02:43

I kinda lost interest in this package. Orphaning now, please feel free to adopt.

padfoot commented on 2011-10-09 04:29

I know this is a stupid question, but if LightDM is a gtk greeter, why does this package depend on qt? Looking at the other package (LightDM - which currently doesn't build) there is no qt requirement, yet this bzr version does????

Sorry, I'm lost.

I really want to replace my (SLIMcurrently) DM - don't want GDM because of the gnome-shell requirements, KDM well that will just bring in heavy kde libraries and qt, LXDM worked once then fails to give me access to my home directory, SLIM I believe is unmaintained.

Would love to try LightDM, but why qt???

Cheers.

cedeel commented on 2011-09-27 08:10

Please add provides=(lightdm) in your PKGBUILD

Anonymous comment on 2011-08-17 15:36

The default python.patch has syntax errors, you need to comment out any lines that are not part of the code. I cannot change the original file (won't pass the check), so I made another file with this correction and pointed the patch to that.

pisuka commented on 2011-06-08 13:00

that's from ubuntu, right? also, this is a "trunk package", it always installs the latest version (534 as of this writing).

Jristz commented on 2011-06-05 19:54

lightd last vesion in bazaar is 502

Jristz commented on 2011-05-30 00:36

Package relationships
Depends on:
adduser
debconf (>= 0.5)
libc6 (>= 2.4)
libdbus-1-3 (>= 1.0.2)
libdbus-glib-1-2 (>= 0.88)
libglib2.0-0 (>= 2.22.0)
libpam-modules
libpam-runtime (>= 0.76-14)
libpam0g (>= 0.99.7.1)
libxcb1
libxdmcp6
upstart-job
Provides:
x-display-manager
Recommends:
lightdm-theme-gnome
xserver-xorg